Results 1 to 6 of 6

Thread: zimbra upgrade to 4.0.4

  1. #1
    Join Date
    May 2006
    Posts
    81
    Rep Power
    9

    Default zimbra upgrade to 4.0.4

    I am upgrading to 4.0.4 from 3.something ...

    Trick is to transfer all the e-mails and data over ... I figured out most everything ...

    But the Notebook stuff is a problem and also now when I add a new user I get
    an error ...

    The procedure I followed ...

    1. I installed new zimbra 4.04 ... then I mysqldump mailbox1 ... it appears mailbox1 is the Global Document account . I grab the account_id for this user and his e-mail from zimbra database . I also save his ldap data .

    2. I notice database structure has changed ... in zimbra there is an extra table and some extra columns in other tables ...

    3. I delete /opt/zimbra/db /opt/zimbra/index/ /opt/zimbra/store and save them in another directory .

    4. I copy over my old server directories ( db,index and store ) .

    5. I edit localconfig.xml with my old zimbra_mysql_password and my mysql_root_password .

    6. I delete openldap-data directory and slapadd my old ldap data with the Global Documents account included and some Notebook configurations as wel .

    7 . I maker the database modifications in mysql ... and I import mailbox1 that i copied in step 1 and I put that into mailbox729 ; I increment current_volumes.next_mailbox_id .

    8. I make directory store/0/729 and index/0/729 and copy over the stuff I removed before ..

    Then I can log on and view emails and account but when I add a new user and try to view his configuration in Zimbra Admin I get an error whose source is SQLException :

    Unknown column 'mi.imap_id' in field list .

    It is querying mailbox730.mail_item table and can't find the above column ...

    Mailbox730 is a new user I created . When it created him , it failed to add that column which happens to be one of the new columns you guys added for this zimbra version ... so now I am thinking there must be some stored procedures somewhere that I failed to keep but mysql 4.1 doesn't have stored procedures or am I wrong ? I searched all the databases and I can't see anything else important that I am missing . Any ideas ?


    Also when I enable notebooks for a user and I go into his account and click the notebook icon I get an error ... I wil post it in my next message .

  2. #2
    Join Date
    May 2006
    Posts
    81
    Rep Power
    9

    Default

    NOTEBOOK ERRPR :

    message - _2c7e has no properties
    fileName - https://mail2.hostname.ca/js/ZimbraM...v=061115174742
    lineNumber - 47681
    stack - ([object Object],12,null,undefined,[object Object])@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:47681
    (12)@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:47389
    (12)@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:47660
    (12,"_Index",true)@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:47486
    (12,"_Index",true)@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:47491
    (12)@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:49681
    (null,true)@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:49592
    ([object Object],undefined,undefined)@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:50182
    ("notebook")@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:55264
    ([object Object])@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:56267
    apply([object Object],[object Array])@:0
    ([object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:3220
    ([object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:3346
    ("SELECTION",[object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:3162
    ("SELECTION",[object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:8373
    ([object Object])@https://mail2.hostname.ca/js/ZimbraMail_all.js.zgz?v=061115174742:9155
    apply([object Object],[object Array])@:0
    ([object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:3220
    ([object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:3346
    ("onmouseup",[object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:3162
    ("onmouseup",[object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:8373
    ([object MouseEvent],"onmouseup",[object Object])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:9105
    ([object MouseEvent])@https://mail2.hostname.ca/js/Ajax_all.js.zgz?v=061115174742:9015
    @:0

    name - TypeError

  3. #3
    Join Date
    May 2006
    Posts
    81
    Rep Power
    9

    Default

    The SQL Error :

    Message: system failure: fetching folder data for mailbox 730
    com.zimbra.cs.service.ServiceException: system failure: fetching folder data for mailbox 730
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:174)
    at com.zimbra.cs.db.DbMailItem.getFoldersAndTags(DbMa ilItem.java:1153)
    at com.zimbra.cs.mailbox.Mailbox.loadFoldersAndTags(M ailbox.java:1434)
    at com.zimbra.cs.mailbox.Mailbox.beginTransaction(Mai lbox.java:804)
    at com.zimbra.cs.mailbox.Mailbox.beginTransaction(Mai lbox.java:762)
    at com.zimbra.cs.mailbox.Mailbox.createMailbox(Mailbo x.java:1327)
    at com.zimbra.cs.mailbox.Mailbox.getMailboxByAccountI d(Mailbox.java:1051)
    at com.zimbra.cs.mailbox.Mailbox.getMailboxByAccountI d(Mailbox.java:1010)
    at com.zimbra.cs.service.admin.GetMailbox.handle(GetM ailbox.java:70)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:261)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:162)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:173)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.sql.SQLException: Unknown column 'mi.imap_id' in 'field list'

    Query being executed when exception was thrown:

    SELECT mi.id, mi.type, mi.parent_id, mi.folder_id, mi.index_id, mi.imap_id, mi.date, mi.size, mi.volume_id, mi.blob_digest, mi.unread, mi.flags, mi.tags, mi.subject, mi.metadata, mi.mod_metadata, mi.change_date, mi.mod_content FROM mailbox730.mail_item mi WHERE type IN (1,2,13,3)
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:2928)
    at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:15 71)
    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(MysqlIO.java :1666)
    at com.mysql.jdbc.Connection.execSQL(Connection.java: 2994)
    at com.mysql.jdbc.PreparedStatement.executeInternal(P reparedStatement.java:936)
    at com.mysql.jdbc.PreparedStatement.executeQuery(Prep aredStatement.java:1030)
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeQuery(DelegatingPreparedStatement.java:20 5)
    at com.zimbra.cs.db.DbMailItem.getFoldersAndTags(DbMa ilItem.java:1091)
    ... 29 more

    Error code: service.FAILURE
    Method: ZmCsfeCommand.prototype.invoke
    Details:soap:Receiver

  4. #4
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default ./install.sh

    The supported upgrade path is to download the 4.0.4 package, back up your existing /opt/zimbra, and run ./install.sh from the 4.0.4 installer. It will upgrade your LDAP and database schemas as it installs the new version. If things go wrong, you can restore your old /opt/zimbra and things should continue to run as before.

    We really can't support attempts to hand-migrate the database and LDAP. It's very very unlikely that you can get everything correct.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  5. #5
    Join Date
    May 2006
    Posts
    81
    Rep Power
    9

    Default

    I will have to try the upgrade ... the problem is we are moving to a new server and new OS . Will that still work ? Its from Fedora to Debian . So if I do upgrade of existing server and copy over /opt/zimbra to Debian , is that going to be OK ?

    In the meantime if anyone has any ideas let me know ... it is a real mystery because I think I have everything covered in MySQL and LDAP .

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by sasha View Post
    I will have to try the upgrade ... the problem is we are moving to a new server and new OS . Will that still work ? Its from Fedora to Debian.
    There are several threads in the forums about moving zimbra to new hardware and/or o/s, do a search for the details.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  2. Replies: 31
    Last Post: 12-15-2007, 09:05 PM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 11:34 PM
  4. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM
  5. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •