Results 1 to 4 of 4

Thread: zmmailboxd not running

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default zmmailboxd not running

    ZCS-8.0-GA on SLES11 SP2. Once a day the email goes down. zmcontrol status
    Host mail.domain.com
    antispam Running
    antivirus Running
    ldap Running
    logger Running
    mailbox Stopped
    zmmailboxdctl is not running.
    mta Running
    snmp Running
    spell Running
    stats Running
    zmconfigd Running

    Nothing shows in /opt/logs/mailbox.log. Is there somewhere else i should be looking to see what is going on?
    We were on 7.2 and upgraded to 8, this broke the entire system. I copied the broken instance somewhere and uninstalled zimbra 8. Then reinstalled zcs 8. Since then, zcs8 will go down once a day.

    Found this in zmmailboxd.out:
    Total time for which application threads were stopped: 0.0005840 seconds
    2012-10-31 11:30:29.922:INFOejpw.PlusConfiguration:No Transaction manager found - if your webapp requires one, please configure one.
    2012-10-31 11:30:29.955:WARNejpw.PlusDescriptorProcessor:No value for env-entry-name trustedIPs
    Error occurred during initialization of VM
    Could not reserve enough space for object heap

    This error is after running zmstorectl start
    Last edited by carnold; 10-31-2012 at 09:33 AM.

  2. #2
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    tail -f on these files:
    /opt/zimbra/logs/mailbox.log
    /opt/zimbra/logs/zmmailboxd.out

    and zmmailboxdctl restart shows
    rror occurred during initialization of VM
    Could not reserve enough space for object heap
    Error occurred during initialization of VM
    Could not reserve enough space for object heap

    I havent tweaked java/zimbra in any way (other than bind to a specific ip address). This is not a virtual install

    I mentioned in the first post that i copied the broken instance of zcs8. After the crash, uninstall and reinstall of zcs8, i then used zmlmtpinject to put back some msg messages. Would this cause the working zcs8 install to crash?
    Last edited by carnold; 10-31-2012 at 10:15 AM.

  3. #3
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    Quote Originally Posted by carnold View Post
    I mentioned in the first post that i copied the broken instance of zcs8. After the crash, uninstall and reinstall of zcs8, i then used zmlmtpinject to put back some msg messages. Would this cause the working zcs8 install to crash?
    Maybe this has something to do with the importing of users email into the zcs8 install? Here why, zmlmtpinject did not meet our needs to get email in users mailbox so i used option 4, thick client namely outlook. After dragging all the users email into a recovery folder, zmmailboxd is not running. Zmmailboxd.out shows the same error as above:
    Error occurred during initialization of VM
    Could not reserve enough space for object heap

    Can anyone help me get this working? How do i see what the current setting is for the java heap?

    mlocalconfig mailboxd_java_heap_memory_percent
    gave
    Warning: null valued key 'mailboxd_java_heap_memory_percent'
    Last edited by carnold; 10-31-2012 at 11:28 AM.

  4. #4
    Join Date
    Jul 2007
    Posts
    227
    Rep Power
    8

    Default

    Closest i could see:
    mailboxd_java_heap_new_size_percent = 25

    Do i need to muk with this or not?

    I guess not...!! I ran zmlocalconfig mailboxd_java_heap_new_size_percent = 30 and got:
    Warning: null valued key '='
    Warning: null valued key '30'

    Then ran zmlocalconfig mailboxd_java_heap_new_size_percent=30 and got:
    Warning: null valued key 'mailboxd_java_heap_new_size_percent=30'

    Then saw the heap error in zmmailbox.out. Can anyone out there offer any help? Does importing email from a 7.x install into a 8 install cause this issue? Is this a java issue? Am i on the right track? Anyone offer any help?
    Last edited by carnold; 10-31-2012 at 11:45 AM.

Similar Threads

  1. zmmailboxd
    By efloyd in forum Installation
    Replies: 15
    Last Post: 10-10-2011, 09:09 PM
  2. zmmailboxd.pid problem
    By johjoh2k in forum Administrators
    Replies: 6
    Last Post: 08-03-2011, 12:11 AM
  3. zmmailboxd not running
    By jerkykid in forum Administrators
    Replies: 15
    Last Post: 02-17-2011, 11:02 PM
  4. zmmailboxd not running
    By jerkykid in forum Installation
    Replies: 2
    Last Post: 08-03-2010, 10:06 AM
  5. [SOLVED] zmmailboxd not running
    By workinonit in forum Installation
    Replies: 2
    Last Post: 10-19-2009, 12:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •