Results 1 to 8 of 8

Thread: Zimbra OpenSource Latest release 8 Multi server install Help

  1. #1
    Join Date
    Feb 2011
    Posts
    42
    Rep Power
    4

    Default Zimbra OpenSource Latest release 8 Multi server install Help

    Hi All,

    I am trying to get a basic Zimbra 8 Open Source Multiserver install to work. Setup work 3 servers with 2CPU, 3GB RAM & 15GB HDD. Loaded RHEL 6.2 64 bit OS. DNS is setup and working OK (tested). Total 3 servers installed:
    LDAP Master server
    Mailstore server
    MTA server.
    Install goes thro fine. After install rebooted all the servers and checked for zimbra services. All are running fine. However when I login to admin console it says the the services on LDAP and MTA servers are all down. Only Mailstore server services are shown as running Ok. Any help would be highly appreciated.
    admin-console.PNG


    Once this is done, the final plan is to add one more mailstore server, one more MTA server, IMAP/POP Proxy server, HTTP proxy server. Any tips on how to do this will be of great help.

    Thanks

  2. #2
    Join Date
    Jan 2009
    Posts
    66
    Rep Power
    6

    Default

    There's not much detail about your actual install, so just a couple of wild guesses here:
    1) did you run the zimupdateauthkeys on each server? otherwise the admin server cannot login to each other server.
    2) did you also update your syslog.conf as per the install notes for the syslogger?
    Release 7.2.0_GA_2669.UBUNTU10_64 UBUNTU10_64 FOSS edition

  3. #3
    Join Date
    Feb 2011
    Posts
    42
    Rep Power
    4

    Default

    Thanks for the response. Yes I followed the install doc (pdf). I overlooked the selinux part. Realized it and turned it off on all servers, rebooted all the servers and checked. Selinux is disabled now. Manually checked services on all servers (zmcontrol status) & all are up. After that I ran zmupdateauthkeys again. From the admin console I can now manage all the 3 servers. However the monitoring tab still shows the others services as down.


    Regards

  4. #4
    Join Date
    Feb 2011
    Posts
    42
    Rep Power
    4

    Default

    I have gone ahead and re-installed all the servers from scratch (re-install OS) religiously following the Multiserver install guide for Zimbra 8, including the final steps (zmupdateauthkeys & logging). Still the same issue persists. What logs I should be looking into to get any clue? Any help is highly appreciated.

    Thanks

  5. #5
    Join Date
    Feb 2011
    Posts
    42
    Rep Power
    4

    Default

    Quote Originally Posted by sviriyala View Post
    I have gone ahead and re-installed all the servers from scratch (re-install OS) religiously following the Multiserver install guide for Zimbra 8, including the final steps (zmupdateauthkeys & logging). Still the same issue persists. What logs I should be looking into to get any clue? Any help is highly appreciated.

    Thanks
    Never mind. I was a bit hasty in posting. I can see all the services running fine in the Admin GUI console. Guess it took a while for the GUI to get updated.

    Now coming back to the original question, how do I add more mailbox servers, MTA servers & more importantly IMAP/POP3 & Web Proxy servers?

    My question is, while installing the MailStore server, I set the SMTP Host as zm-mta.cmcltd.org (hoping that the DNS round robin would take care of the multiple servers. Similarly while installing MTA server I tried to set the MTA Auth Host as zm-store.cmcltd.org, but that didn't work. While installing it gave the error "Setting MTA AUth host ..Failed". SO had to uninstall everything and set it to zm-store1.cmcltd.org (which is the mailstore server). (I tried to refer the AJCody's Multiserver install notes in the Wiki and tried to follow that example).

    Can anyone help me with this?

    Thanks

  6. #6
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    4

    Default

    Quote Originally Posted by sviriyala View Post
    Never mind. I was a bit hasty in posting. I can see all the services running fine in the Admin GUI console. Guess it took a while for the GUI to get updated.

    Now coming back to the original question, how do I add more mailbox servers, MTA servers & more importantly IMAP/POP3 & Web Proxy servers?

    My question is, while installing the MailStore server, I set the SMTP Host as zm-mta.cmcltd.org (hoping that the DNS round robin would take care of the multiple servers. Similarly while installing MTA server I tried to set the MTA Auth Host as zm-store.cmcltd.org, but that didn't work. While installing it gave the error "Setting MTA AUth host ..Failed". SO had to uninstall everything and set it to zm-store1.cmcltd.org (which is the mailstore server). (I tried to refer the AJCody's Multiserver install notes in the Wiki and tried to follow that example).

    Can anyone help me with this?

    Thanks
    this is based on my experience with ZCS NE 7.1

    MTA/SMTP points the public name of mailbox server

  7. #7
    Join Date
    Feb 2011
    Posts
    42
    Rep Power
    4

    Default

    Quote Originally Posted by malayo View Post
    this is based on my experience with ZCS NE 7.1

    MTA/SMTP points the public name of mailbox server
    I am not sure I quite follow. When I have multiple mailstore servers and multiple MTA servers for the same domain, each having its own hostname (naturally), which ones do I use in the installation? When I install Mailstore servers, it asks for SMTP Host. WHat name do I enter there? Similarly when I install MTA server, it asks for MTA Auth host (which basically needs to point to Mailstore server). Which hostname do I enter there? Or is there a provision to enter multiple addresses? I am not very clear on this concept.

    Thanks

  8. #8
    Join Date
    Apr 2011
    Posts
    117
    Rep Power
    4

    Default

    Quote Originally Posted by sviriyala View Post
    I am not sure I quite follow. When I have multiple mailstore servers and multiple MTA servers for the same domain, each having its own hostname (naturally), which ones do I use in the installation? When I install Mailstore servers, it asks for SMTP Host. WHat name do I enter there? Similarly when I install MTA server, it asks for MTA Auth host (which basically needs to point to Mailstore server). Which hostname do I enter there? Or is there a provision to enter multiple addresses? I am not very clear on this concept.

    Thanks
    in my case, i will use its red hat cluster's service name

Similar Threads

  1. Migrating from Zimbra 5.0.10 to latest release
    By MGSteve in forum Administrators
    Replies: 7
    Last Post: 03-09-2012, 05:01 AM
  2. Migrating from Zimbra 5.0.10 to latest release
    By MGSteve in forum Migration
    Replies: 0
    Last Post: 02-27-2012, 06:37 AM
  3. Multi-country, multi-server install: logger issue
    By Hivos in forum Administrators
    Replies: 0
    Last Post: 09-06-2010, 02:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •