Results 1 to 7 of 7

Thread: Unable to login after reverting to HTTP mode

  1. #1
    Join Date
    Sep 2009
    Posts
    13
    Rep Power
    6

    Exclamation Unable to login after reverting to HTTP mode

    Hi,

    I just made a fresh-install of ZCS 8.0.1 on a test server and after reading the changelog discovered the HTTPS login method by default.

    I found these steps zmtlsctl from ZCS 6 and followed it trying to enable both HTTP and HTTPS methods for login, but after the restart of zmmailbox I can not login anymore. It says "Session expired" all the time with every account.

    The mailbox.log says:

    2012-11-22 13:41:26,544 INFO [qtp1573904213-85:http://127.0.0.1:80/service/soap/AuthRequest] [name=xxx@xxx.com.br;oip=xxx.xxx.xxx.xxx;ua=zclient/8.0.1_GA_5438;] soap - AuthRequest elapsed=5
    2012-11-22 13:41:26,551 ERROR [qtp1573904213-76:https://xxx.xxx.xxx.xxx:443/] [] webclient - auth credentials have expired
    com.zimbra.common.soap.SoapFaultException: auth credentials have expired
    ExceptionId:qtp1573904213-85:http://127.0.0.1:80/service/soap/Aut...a51fd041cc9616
    Code:service.AUTH_EXPIRED
    at com.zimbra.common.soap.Soap12Protocol.soapFault(So ap12Protocol.java:88)
    at com.zimbra.common.soap.SoapTransport.extractBodyEl ement(SoapTransport.java:333)
    at com.zimbra.common.soap.SoapTransport.parseSoapResp onse(SoapTransport.java:308)
    at com.zimbra.common.soap.SoapHttpTransport.invoke(So apHttpTransport.java:255)
    at com.zimbra.common.soap.SoapHttpTransport.invoke(So apHttpTransport.java:167)
    at com.zimbra.common.soap.SoapTransport.invoke(SoapTr ansport.java:386)
    at com.zimbra.client.ZMailbox.invoke(ZMailbox.java:61 3)
    at com.zimbra.client.ZMailbox.invoke(ZMailbox.java:60 7)
    at com.zimbra.client.ZMailbox.invokeJaxb(ZMailbox.jav a:602)
    at com.zimbra.client.ZMailbox.authByAuthToken(ZMailbo x.java:561)
    at com.zimbra.client.ZMailbox.<init>(ZMailbox.java:45 1)
    at com.zimbra.client.ZMailbox.getMailbox(ZMailbox.jav a:398)
    at com.zimbra.cs.taglib.tag.LoginTag.doTag(LoginTag.j ava:134)
    at org.apache.jsp.public_.login_jsp._jspService(login _jsp.java:379)
    at org.apache.jasper.runtime.HttpJspBase.service(Http JspBase.java:109)

    Even after changing the mode back to HTTPS I receive the same error.

    Any ideas how to solve this?

    Thank you in advance.

    Diego

  2. #2
    Join Date
    Aug 2007
    Posts
    220
    Rep Power
    8

    Default

    Did you set the mode to both, mixed, redirect, or what?

  3. #3
    Join Date
    Sep 2009
    Posts
    13
    Rep Power
    6

    Default

    I tried all the modes without success. The first one was "both"

  4. #4
    Join Date
    Aug 2007
    Posts
    220
    Rep Power
    8

    Default

    Out of curiosity, what is the authentication token lifetime set to for that domain/cos?

  5. #5
    Join Date
    Sep 2009
    Posts
    13
    Rep Power
    6

    Default

    Quote Originally Posted by Vladimir View Post
    Out of curiosity, what is the authentication token lifetime set to for that domain/cos?
    Actually until November 2017, the default lifetime has changed from 1 to 5 years with ZCS 8.

    Probably the root cause is something with the command zmtlsctl changing some file with different behavior between ZCS 6 and 8, but I don`t want to report a bug until i`m sure about this.

  6. #6
    Join Date
    Aug 2007
    Posts
    220
    Rep Power
    8

    Default

    I think you misunderstood what I asked, not the license lifetime, I mean how long can a user stay logged in without relogging, what is that set to?

  7. #7
    Join Date
    Sep 2009
    Posts
    13
    Rep Power
    6

    Default

    Quote Originally Posted by Vladimir View Post
    I think you misunderstood what I asked, not the license lifetime, I mean how long can a user stay logged in without relogging, what is that set to?
    Ah ok, the auth token was set the default for 2 days.

    Well I gave up on this case, since it was a test environment I just wiped out this installation and did a new one, this time using https again... I`ll try to find a way how to enable HTTP mode again.

    Thank you very much Vladimir.

Similar Threads

  1. Can't login to zimbra on http://xxx.xxx.xxx.xxx:5480
    By antuprabha in forum Installation
    Replies: 1
    Last Post: 10-02-2010, 07:15 AM
  2. change web server mode from http to redirect?
    By tiger2000 in forum Administrators
    Replies: 1
    Last Post: 06-30-2010, 12:50 PM
  3. [SOLVED] Unable to send after mode change
    By dkbk in forum Administrators
    Replies: 10
    Last Post: 07-17-2009, 08:36 AM
  4. Can Admin login url be http
    By Shikha Sood in forum Administrators
    Replies: 0
    Last Post: 08-06-2008, 05:51 AM
  5. Unable to revert to http mode
    By SuperBeaker in forum Installation
    Replies: 3
    Last Post: 03-09-2008, 01:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •