Results 1 to 5 of 5

Thread: ZCS 8 FOSS - Web proxy Issues

Hybrid View

  1. #1
    Join Date
    Feb 2011
    Rep Power

    Thumbs up ZCS 8 FOSS - Web proxy Issues

    Hi All,

    I have a strange issue with Web Proxy. My Config is a Multiserver install on RHEL 6.2 64 bit. Have Web Proxy installed on a separate box. The issue is while I am able to login using web sometimes, at other times (seems quite random) it re-directs the requests directly to the mailbox server. And I am not getting a clue as to when this happens? Isn't the whole idea of proxy that the user doesn't directly connect to the mailbox server? I have been trying to look at the log files (/opt/zimbra/log/ nginx.log & nginx.access.log). No clue.

    For exampl: works fine some times ( being the web proxy host

    and at other times the moment I login it immediately re-directs the url to or

    This is happening with all accounts, on different PCs. I even tried clearing the cache & other stuff in the browsers, restart the browser etc, still it happens. And at other times it logins perfectly.

    Any clue is highly appreciated.

    Last edited by sviriyala; 11-26-2012 at 05:51 AM.

  2. #2
    Join Date
    Feb 2011
    Rep Power


    With no help at all, I further tried to find out some clue the hard way. Tried even packet capture from client side. Eventually this is one thing I noticed.


    I had kept a putty session open on the http proxy server with the following command
    #tail -f nginx.access.log

    I opened a browser (IE9) & got to the login page:

    At this point I marked the last message i the above log file. Then tried to login, and captured all the lines that came in. Later after several unsuccessful logins, waited till I was able to successfully login and then again, captured the output of the log. Then compared the lines. The very first line differs with different http codes as shown below:

    Unsuccessful Login: - - [26/Nov/2012:00:27:00 +0530] "POST / HTTP/1.1" 200 1265 "" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0)"
    SUCCESSFUL LOGIN: - - [26/Nov/2012:00:34:07 +0530] "POST / HTTP/1.1" 302 0 "" "Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0)"
    Notice that during unsuccesful login I get a HTTP code of 200 while during successful login I get HTTP code 302.

    Any idea as to why this is happening and what is causing this?


  3. #3
    Join Date
    Feb 2011
    Rep Power


    So much for my 'debugging' over the past 4/5 days. This seems to be a known issue in Zimbra. Finally found the solution thro a KB article on VMWare site itself. Here is the link:

    VMware KB: Web log in through reverse proxy redirects to mailstore

    Posting it for the benefit of others who might search/post in the forum.


  4. #4
    Join Date
    Aug 2007
    Rep Power


    I've just ran into this after an upgrade to 7.2.2

    My problem is that the mailstores already have these options set correctly so for me the KB article doesn't really help.

  5. #5
    Join Date
    Feb 2014
    Rep Power


    (This answer is for those who have met this issue)
    Your problem is due the configuration parameter "zimbraMailReferMode" which it's value is "wronghost" (i think )
    Use the following command to check it (on you reverse-proxy Server):
    zimbra$ zmprov gcf zimbraMailReferMode
    You should change it to "reverse-proxied" using the following commands
    zimbra$ zmprov mcf zimbraMailReferMode reverse-proxied

    and then restart your rev-proxy server

    Best regards

Similar Threads

  1. Zimbra FOSS 8 and Foss community backup script
    By drdre in forum Administrators
    Replies: 3
    Last Post: 06-19-2013, 03:58 AM
  2. ZCS 7.2 Through Apache Reverse Proxy Over HTTPS Issues
    By Abeckhardt in forum Administrators
    Replies: 1
    Last Post: 04-25-2013, 04:09 PM
  3. Issues with nginx proxy
    By uxbod in forum Administrators
    Replies: 8
    Last Post: 02-18-2010, 06:37 AM
  4. Replies: 6
    Last Post: 10-31-2009, 02:54 AM
  5. Replies: 19
    Last Post: 07-09-2009, 09:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts