Results 1 to 2 of 2

Thread: Installing self signed certificates on migration

  1. #1
    Join Date
    Nov 2012
    Posts
    2
    Rep Power
    3

    Default Installing self signed certificates on migration

    Hi,

    I'm migrating from 7.2.1 on CentOS to 7.2.1 on Ubuntu.

    I've already imported all ldap datas, index files and databases data ( still waiting for the message stores as is something like 140GB of messages ).

    I'm stuck with the self signed certificate deployment as follows:

    Code:
    root@zimbra:/tmp# /opt/zimbra/bin/zmcertmgr createca -new
    ** Creating /opt/zimbra/ssl/zimbra/ca/zmssl.cnf...done
    ** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.
    ** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.
    And then:

    Code:
    root@zimbra:/tmp# /opt/zimbra/bin/zmcertmgr deployca -localonly
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...failed.
    
    keytool error: java.io.IOException: Keystore was tampered with, or password was incorrect
    
    ** Copying CA to /opt/zimbra/conf/ca...done.
    Here's the full zimbra version:
    Code:
    Release 7.2.1_GA_2790.UBUNTU10_64 UBUNTU10_64 FOSS edition.
    Can anyone help me?

    Thanks in advance.

    Andrea.

  2. #2
    Join Date
    Nov 2012
    Posts
    2
    Rep Power
    3

    Exclamation Becoming urgent..

    While the error is still not resolved, I tried to ignore it as no errors has come out. When starting services via zmcontrol start it says that all services are started, but after everything started up i can see that zmmailboxd is not running:

    Code:
    zimbra@zimbra:~$ zmcontrol status
    Host zimbra.euchia.it
    	antispam                Running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Stopped
    		zmmailboxdctl is not running.
    	mta                     Running
    	stats                   Running
    	zmconfigd               Running
    I can see in the logs that zmmailboxdctl and zmstorectl are not running and returning 1

    Code:
    ==> /opt/zimbra/log/zmconfigd.log <==
    2012-11-25 11:54:05,661 zmconfigd WARNING [32276-MainThread] Fetching All configs
    2012-11-25 11:54:06,384 zmconfigd WARNING [32276-MainThread] All configs fetched in 0.72 seconds
    2012-11-25 11:54:07,588 zmconfigd ERROR [32276-MainThread] Executed: /opt/zimbra/bin/zmstorectl status norewrite returned 1 (30 - 13) (0.14 sec)
    2012-11-25 11:54:07,589 zmconfigd CRITICAL [32276-MainThread] Tracking service mailbox 
    2012-11-25 11:54:07,661 zmconfigd ERROR [32276-MainThread] Executed: /opt/zimbra/bin/zmmailboxdctl status norewrite returned 1 (25 - 13) (0.07 sec)
    2012-11-25 11:54:07,661 zmconfigd CRITICAL [32276-MainThread] Tracking service mailboxd 
    2012-11-25 11:54:10,048 zmconfigd WARNING [32276-MainThread] Watchdog: skipping service antivirus. Service not yet available for restarts.
    2012-11-25 11:54:10,426 zmconfigd WARNING [32276-MainThread] All rewrite threads completed in 0.01 sec
    2012-11-25 11:54:10,427 zmconfigd WARNING [32276-MainThread] All restarts completed in 0.00 sec
    Starting zmconfigd...zmconfigd is already running.
    And in the zmmailboxd.out log this error is thrown if I try giving zmstorectl start:
    Code:
    0    INFO  [main] log - Logging to org.slf4j.impl.Log4jLoggerAdapter(org.mortbay.log) via org.mortbay.log.Slf4jLog
    Zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Zimbra server reserving server socket port=995 bindaddr=null ssl=true
    Fatal error: exception while binding to ports
    java.net.SocketException: Unbound server sockets not implemented
    	at javax.net.ServerSocketFactory.createServerSocket(ServerSocketFactory.java:80)
    	at com.zimbra.common.util.NetUtil.newBoundServerSocket(NetUtil.java:95)
    	at com.zimbra.common.util.NetUtil.bindServerSocket(NetUtil.java:163)
    	at com.zimbra.common.util.NetUtil.bindSslTcpServerSocket(NetUtil.java:54)
    	at com.zimbra.common.handlers.PrivilegedHandler.openPorts(PrivilegedHandler.java:82)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.xml.XmlConfiguration.call(XmlConfiguration.java:542)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:252)
    	at org.mortbay.xml.XmlConfiguration.configure(XmlConfiguration.java:214)
    	at org.mortbay.xml.XmlConfiguration.main(XmlConfiguration.java:974)
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    	at java.lang.reflect.Method.invoke(Method.java:597)
    	at org.mortbay.start.Main.invokeMain(Main.java:194)
    	at org.mortbay.start.Main.start(Main.java:534)
    	at org.mortbay.start.Main.start(Main.java:441)
    	at org.mortbay.start.Main.main(Main.java:119)
    Can Anyone please help? I've searched all over the forums but nothing worked out.

Similar Threads

  1. Trusting self-signed certificates
    By EnSn in forum Administrators
    Replies: 5
    Last Post: 09-20-2013, 01:32 AM
  2. Self signed certificates and browsers
    By gbarchi in forum Administrators
    Replies: 7
    Last Post: 10-14-2011, 07:45 AM
  3. Self signed certificates and browsers
    By gbarchi in forum Installation
    Replies: 0
    Last Post: 10-13-2011, 09:48 AM
  4. Setting up iPhones with self-signed SSL certificates
    By Baylink in forum Zimbra Mobile
    Replies: 7
    Last Post: 04-07-2010, 09:13 AM
  5. Replies: 2
    Last Post: 06-25-2009, 09:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •