I'm a bit confused. I can see releases of the 8.0 series, but there are only 64-bit versions. I'm using an older install of Ubuntu (10.04). Version 7.1.x runs just fine in this environment, and my hardware is very old and really doesn't behave well with Ubuntu 12.04. Am I stuck at this version? It's okay, I guess. Or am I misunderstanding something?

Thanks.