Results 1 to 6 of 6

Thread: SMTP relaying exemption

  1. #1
    Join Date
    Sep 2012
    Posts
    19
    Rep Power
    3

    Default SMTP relaying exemption

    Hi,

    How can I allow a certain address to use SMTP relaying.
    example I use:
    Email Server Test - Online SMTP diagnostics tool - MxToolbox

    I am getting this result:

    MAIL FROM: <supertool@mxtoolbox.com>
    250 2.1.0 Ok [31 ms]
    RCPT TO: <test@example.com>
    554 5.7.1 <test@example.com>: Relay access denied [31 ms]

    In /var/log/zimbra.log

    Dec 6 22:24:34 zimbra postfix/smtpd[27983]: NOQUEUE: reject: RCPT from mxtb-pws3.mxtoolbox.com[64.20.227.133]: 554 5.7.1 <test@example.com>: Relay access denied; from=<supertool@mxtoolbox.com> to=<test@example.com> proto=ESMTP helo=<please-read-policy.mxtoolbox.com>

    How can I add this address 64.20.227.133 to allow relaying.
    I have tried this,

    zmprov modifyServer zimbra.example.com zimbraMtaMyNetworks '127.0.0.0/8 64.20.227.133/32'
    postfix reload

    (I have removed the IP of zimbra at the example above)
    but it is not working.
    Last edited by juanpablo; 12-09-2012 at 07:26 PM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by juanpablo View Post
    How can I allow a certain address to use SMTP relaying.
    If you mean through your server then you should not use port 25, the corect submission port which is 587 and that will require authentication by the client, you certainly do want to allow anyone to relay through your server without authentication - think of 'spammer'.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2009
    Location
    China
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by juanpablo View Post
    Hi,

    How can I allow a certain address to use SMTP relaying.
    example I use:
    Email Server Test - Online SMTP diagnostics tool - MxToolbox

    I am getting this result:

    MAIL FROM: <supertool@mxtoolbox.com>
    250 2.1.0 Ok [31 ms]
    RCPT TO: <test@example.com>
    554 5.7.1 <test@example.com>: Relay access denied [31 ms]

    In /var/log/zimbra.log

    Dec 6 22:24:34 zimbra postfix/smtpd[27983]: NOQUEUE: reject: RCPT from mxtb-pws3.mxtoolbox.com[64.20.227.133]: 554 5.7.1 <test@example.com>: Relay access denied; from=<supertool@mxtoolbox.com> to=<test@example.com> proto=ESMTP helo=<please-read-policy.mxtoolbox.com>

    How can I add this address 64.20.227.133 to allow relaying.
    I have tried this,

    zmprov modifyServer zimbra.example.com zimbraMtaMyNetworks '127.0.0.0/8 64.20.227.133/32'
    postfix reload

    (I have removed the IP of zimbra at the example above)
    but it is now working.
    It is sensitive in linux with "Server" and "server". Make sure you have executed suitable command.
    It`ll be easier to achieve it in web console. Add the ip you want to apply relay service.

    But it is now working or it is not working ?
    Just do it.
    覧覧覧覧覧覧覧
    QQ:307741085
    Email:fine@zcsmail.com

  4. #4
    Join Date
    Sep 2012
    Posts
    19
    Rep Power
    3

    Default

    Quote Originally Posted by xuyanru View Post
    It is sensitive in linux with "Server" and "server". Make sure you have executed suitable command.
    It`ll be easier to achieve it in web console. Add the ip you want to apply relay service.

    But it is now working or it is not working ?
    oh sorry, it should be "not" not "now". I have edited my original post.

    About the capital "S", I just copy paste the command from zimbra wiki, it should be capital "S". Anyway you are right, it is better and safer to use the web console.

  5. #5
    Join Date
    Sep 2012
    Posts
    19
    Rep Power
    3

    Default

    Quote Originally Posted by phoenix View Post
    If you mean through your server then you should not use port 25, the corect submission port which is 587 and that will require authentication by the client, you certainly do want to allow anyone to relay through your server without authentication - think of 'spammer'.
    OK I will try port 587 and with authentication.
    What strange is, I tried another web SMTP mail server test:
    https://www.wormly.com/test_smtp_server

    You need to input only:
    SMTP server
    Sender email
    Recipient email

    and it is successful. It successfully sends the mail to the recipient email with no authentication. I have not also added their IP in my MTA trusted networks. Now my concern is, if my zimbra mail server is open to relay, then this is a big problem.
    Last edited by juanpablo; 12-09-2012 at 10:29 PM.

  6. #6
    Join Date
    Oct 2009
    Location
    China
    Posts
    34
    Rep Power
    6

    Default

    telnet YourMailHost 25
    ehlo mail.xx.com
    ...
    mail from:abc@cde.com
    250 2.1.0 Ok
    rcpt to:123@321.com
    here is the key words of the output

    If your mail system reply with "250 2.1.0 Ok" after your command of rcpt to, it means your system is a open relay system. Otherwise it is normal.
    Just do it.
    覧覧覧覧覧覧覧
    QQ:307741085
    Email:fine@zcsmail.com

Similar Threads

  1. Replies: 1
    Last Post: 04-22-2011, 10:19 AM
  2. SMTP Relaying Auth Issue with TLS enabled
    By reza225 in forum Administrators
    Replies: 2
    Last Post: 04-29-2007, 09:47 AM
  3. Relaying
    By Fox in forum Installation
    Replies: 1
    Last Post: 06-14-2006, 08:39 AM
  4. Supporting SPA and TLS for SMTP relaying
    By pbwebguy in forum Installation
    Replies: 1
    Last Post: 05-18-2006, 07:59 AM
  5. Default SMTP/Relaying Policy
    By macguru in forum Administrators
    Replies: 1
    Last Post: 04-09-2006, 09:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •