After a fresh install of Zimbra 8.0.1 on Ubuntu 12.04, I rebooted and the Zimbra services did not start. Here is what I have done. I have not rebooted yet after performing this procedure. I will keep you posted.

Code:
root@zimbra:~# su - zimbra -c "zmcontrol -v"
Release 8.0.1.GA.5438.UBUNTU12.64 UBUNTU12_64 FOSS edition.

root@zimbra:~# chkconfig --list | grep zimbra
zimbra                    0:off  1:off  2:off  3:off  4:off  5:off  6:off

root@zimbra:~# chkconfig zimbra on
insserv: Script zimbra is broken: incomplete LSB comment.
insserv: missing `Default-Stop:'   entry: please add even if empty.
insserv: Service nscd has to be enabled to start service zimbra
insserv: Service cron has to be enabled to start service zimbra
insserv: exiting now!
/sbin/insserv failed, exit code 1

### Added the follow line to /etc/init.d/zimbra ###
# Default-Stop:   0 1 2 6

### Changed the following line to the line after that ###
# Required-Start: $network $remote_fs $syslog $time ncsd cron
# Required-Start: $network $remote_fs $syslog $time

### Added "2" to Default-Start ###

root@zimbra:~# chkconfig --del zimbra
root@zimbra:~# insserv /etc/init.d/zimbra
### After the above command I get a bunch of errors ###
...clip...
The script you are attempting to invoke has been converted to an Upstart
job, but lsb-header is not supported for Upstart jobs.
insserv: warning: script 'plymouth-upstart-bridge' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `plymouth-upstart-bridge'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `plymouth-upstart-bridge'
The script you are attempting to invoke has been converted to an Upstart
job, but lsb-header is not supported for Upstart jobs.
insserv: warning: script 'screen-cleanup' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `screen-cleanup'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `screen-cleanup'
The script you are attempting to invoke has been converted to an Upstart
job, but lsb-header is not supported for Upstart jobs.
insserv: warning: script 'passwd' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `passwd'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `passwd'
...clip...
root@zimbra:~# chkconfig --list | grep zimbra
zimbra                    0:off  1:off  2:on   3:on   4:on   5:on   6:off
This is a live server, so I will need to reboot at an appropriate time (tonight). I will report back to say if this fixes the issue. If it does, then I would say that Zimbra has a bug in the installation process.