Results 1 to 8 of 8

Thread: Zimbra 8.0.1: imap - too many IMAP requests from account XXX dropping connection

Hybrid View

  1. #1
    Join Date
    Dec 2010
    Location
    Riga
    Posts
    15
    Rep Power
    5

    Default Zimbra 8.0.1: imap - too many IMAP requests from account XXX dropping connection

    I have done clean install of 8.0.1, and trying to migrate emails from Gmail with imapsync.

    I have only one imapsync instance, running on the same Zimbra server, but every time after a random time, Zimbra disconnects my Imap session:
    mailbox.log
    Code:
    2012-12-15 21:03:20,895 INFO  [ImapSSLServer-1] [name=arnis@mydomain.com;mid=20;ip=IPADDRESS;] mailop - Deleting Message (id=42805).
    2012-12-15 21:03:20,897 INFO  [ImapSSLServer-1] [name=arnis@mydomain.com;mid=20;ip=IPADDRESS;] mailop - Deleting Message (id=42806).
    2012-12-15 21:03:20,899 INFO  [ImapSSLServer-1] [name=arnis@mydomain.com;mid=20;ip=IPADDRESS;] mailop - Deleting Message (id=42807).
    2012-12-15 21:03:20,900 INFO  [ImapSSLServer-1] [name=arnis@mydomain.com;mid=20;ip=IPADDRESS;] mailop - Deleting Message (id=42809).
    2012-12-15 21:03:21,409 WARN  [ImapSSLServer-2] [name=arnis@mydomain.com;mid=20;ip=IPADDRESS;] imap - too many IMAP requests from account 3310cebd-abb1-4a4e-8f9e-801a707216f3 dropping connection
    2012-12-15 21:03:21,409 INFO  [ImapSSLServer-2] [name=arnis@mydomain.com;mid=20;ip=IPADDRESS;] imap - dropping connection for user arnis@mydomain.com (server-initiated)
    2012-12-15 21:03:21,611 INFO  [ImapSSLServer-2] [name=arnis@mydomain.com;ip=IPADDRESS;] imap - user arnis@mydomain.com authenticated, mechanism=LOGIN [TLS]
    2012-12-15 21:03:21,613 WARN  [ImapSSLServer-2] [name=arnis@mydomain.com;ip=IPADDRESS;] imap - too many IMAP requests from account 3310cebd-abb1-4a4e-8f9e-801a707216f3 dropping connection
    2012-12-15 21:03:21,613 INFO  [ImapSSLServer-2] [name=arnis@mydomain.com;ip=IPADDRESS;] imap - dropping connection for user arnis@mydomain.com (server-initiated)
    2012-12-15 21:03:21,747 INFO  [ImapSSLServer-1] [name=arnis@mydomain.com;ip=IPADDRESS;] imap - user arnis@mydomain.com authenticated, mechanism=LOGIN [TLS]
    2012-12-15 21:03:21,749 WARN  [ImapSSLServer-1] [name=arnis@mydomain.com;ip=IPADDRESS;] imap - too many IMAP requests from account 3310cebd-abb1-4a4e-8f9e-801a707216f3 dropping connection
    I have changed settings with:
    Code:
    sudo -u zimbra /opt/zimbra/bin/zmprov ms zimbra.SERVER.com zimbraImapMaxConnections 900
    sudo -u zimbra /opt/zimbra/bin/zmprov ms zimbra.SERVER.COM zimbraImapNumThreads 10000
    But nothing has changed.
    Gillar from imapsync is sure - imapsync creats only one session during a run.

    Similar problem here? http://www.zimbra.com/forums/adminis...-exceeded.html
    Release 8.0.1.GA.5438.UBUNTU12.64 UBUNTU12_64 FOSS edition.

  2. #2
    Join Date
    Dec 2009
    Location
    Michigan
    Posts
    454
    Rep Power
    6

    Default

    I had this issue the first time I setup SeaMonkey with Zimbra. I don't recall if after making those changes, if Zimbra needed to be restarted. Below is my IMAP settings:

    Code:
    data_source_imap_reuse_connections = false
    imap_authenticated_max_idle_time = 1800
    imap_inactive_session_cache_size = 10000
    imap_max_consecutive_error = 5
    imap_max_idle_time = 60
    imap_max_request_size = 10240
    imap_thread_keep_alive_time = 60
    imap_throttle_acct_limit = 250
    imap_throttle_command_limit = 25
    imap_throttle_ip_limit = 250
    imap_use_ehcache = true
    imap_write_chunk_size = 8192
    imap_write_timeout = 10
    javamail_imap_debug = false
    javamail_imap_enable_starttls = true
    javamail_imap_test_timeout = 20
    javamail_imap_timeout = 60
    nio_imap_enabled = true
    zimbra_session_limit_imap = 15
    Doug
    Ben Franklin quote:

    "Those who would give up Essential Liberty to purchase a little Temporary Safety, deserve neither Liberty nor Safety."

  3. #3
    Join Date
    Dec 2010
    Location
    Riga
    Posts
    15
    Rep Power
    5

    Default

    I posted bug on Bugzilla, and succesfuly received recomendations on IMAP thorttle setting.
    Based on: https://bugzilla.zimbra.com/show_bug.cgi?id=79262

    Set
    Code:
    zmlocalconfig -e imap_throttle_command_limit=500
    (and restart services)

    This helped for me!
    Release 8.0.1.GA.5438.UBUNTU12.64 UBUNTU12_64 FOSS edition.

  4. #4
    Join Date
    Jun 2014
    Posts
    2
    Rep Power
    1

    Default

    Hi,

    I am having a similar problem, but this has not worked for me, I am getting the following in the log:

    imap - too many IMAP requests from account ... dropping connection

    I have used zmlocalconfig as documented above:

    zmlocalconfig -e imap_throttle_command_limit=50000

    (not that I think 50K is sensible, I just wanted to see if this fixes it), and I still get the issue.

    What I am trying to do is have a java process that downloads 10 emails from the Inbox and writes the attachments to the file system (the attachments are roughly 7MB each, the email itself is tiny they have about 100 chars of content in each one).

    Any thoughts would be appreciated.

    Thanks

    Scott

  5. #5
    Join Date
    Dec 2010
    Location
    Riga
    Posts
    15
    Rep Power
    5

    Question

    Quote Originally Posted by Scott07 View Post
    Hi,

    I am having a similar problem, but this has not worked for me, I am getting the following in the log:

    imap - too many IMAP requests from account ... dropping connection

    I have used zmlocalconfig as documented above:

    zmlocalconfig -e imap_throttle_command_limit=50000

    (not that I think 50K is sensible, I just wanted to see if this fixes it), and I still get the issue.

    What I am trying to do is have a java process that downloads 10 emails from the Inbox and writes the attachments to the file system (the attachments are roughly 7MB each, the email itself is tiny they have about 100 chars of content in each one).

    Any thoughts would be appreciated.

    Thanks

    Scott
    Just to clarify, You have restarted services after config changes, right?
    Release 8.0.1.GA.5438.UBUNTU12.64 UBUNTU12_64 FOSS edition.

  6. #6
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    What ZCS release are you on?
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  7. #7
    Join Date
    Jun 2014
    Posts
    2
    Rep Power
    1

    Default

    Hi,

    Thanks for the help, I have identified the problem now, but to answer the questions first

    Yes after running the command I ran

    zmcontrol stop (as the zimbra user)

    Waited for the command to complete and all the running processes to end then ran

    zmcontrol start

    The release I am running is:
    Release 8.0.6.GA.5922.UBUNTU12.64 UBUNTU12_64 FOSS edition.

    So should anyone else run into this the problem in this case was nothing to do with the server. By default JavaMail (which was the tool using to access the IMAP server) downloads message attachments over IMAP in a vast number of tiny chunks, each chunk uses an IMAP operation which means when your downloading a few 7MB attachments you can very quickly overrun the limit. The simple answer is that you can control this behaviour when initalising JavaMail, setting the chunk size to me much higher (I used 64KB), fixed the problem and made the process faster.

Similar Threads

  1. IMAP - Dropping connection (max connections exceeded)
    By ymarinov in forum Administrators
    Replies: 9
    Last Post: 12-25-2013, 06:14 AM
  2. Dropping IMAP connection during migration
    By RickATMS in forum Administrators
    Replies: 1
    Last Post: 11-29-2010, 10:58 AM
  3. Outlook 2003 dropping IMAP connection after 5.0 GA upgrade
    By Mark Daniel in forum Administrators
    Replies: 7
    Last Post: 01-06-2008, 10:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •