Results 1 to 3 of 3

Thread: Zimbra 7.2.0 (Ubuntu 10.04) to Zimbra 8.0.2 (CentOS 6.3) [FOSS Edition]

  1. #1
    Join Date
    Jan 2011
    Posts
    19
    Rep Power
    4

    Default [SOLVED] Zimbra 7.2.0 (Ubuntu 10.04) to Zimbra 8.0.2 (CentOS 6.3) [FOSS Edition]

    Hi

    Wondering if i could get some help/advice?

    In attempting a migration of Zimbra 7.2.0 (Ubuntu 10.04) to Zimbra 8.0.2 (CentOS 6.3) [FOSS Edition], I think I've made the mistake of upgrading the old server from ZCS 7.2.0 (Ubuntu 10.04) to 8.0.2 (Ubuntu 10.04) and then tried to rsync the data to a new server already running Zimbra 8.0.2 (CentOS 6.3).

    I used various guides from the wiki for platform independent migrations.

    However I now cannot log into user or admin accounts on the upgraded old server now running 8.0.2? The server will also not receive any mail, and gives a '550 5.1.1 user does not exist on this server' error.

    I only received the following error during the uprgrade.

    Code:
    Mon Dec 24 20:21:27 2012 *** Running as zimbra user: /opt/zimbra/libexec/zmslapadd /opt/zimbra/data/ldap/ldap.80
    50d88f25 ldif_read_file: checksum error on "/opt/zimbra/data/ldap/config/cn=config/olcDatabase={2}mdb.ldif"
    Is there a way I can rollback the upgrade of the old server back to ZCS 7.2.0?

    Or is there a way I can fix the authentication problems?

    I've had a look at the following threads;

    http://www.zimbra.com/forums/adminis...dap-error.html

    https://bugzilla.zimbra.com/show_bug.cgi?id=77623

    But not had any joy in resolving the issue.

    Any help appreciated?

    Eli
    Attached Files Attached Files
    Last edited by elijahpaul; 12-28-2012 at 04:07 PM.

  2. #2
    Join Date
    Jan 2011
    Posts
    19
    Rep Power
    4

    Default

    Some more information.

    I deleted the 'cn=config' folder and the 'cn=config.ldif' file in /opt/zimbra/data/ldap/config', and then ran:

    Code:
    /opt/zimbra/openldap/sbin/slapadd -q -n 0 -F /opt/zimbra/data/ldap/config -cv -l /backup/ldap-config.bak
    Which completes without any errors.

    Users can now login and see there emails as normal. However, when logging into the Admin Console, no user accounts are listed. Likewise running 'zmprov gaaa' lists no accounts.

    If I then remove (rename) the data.mdb from /opt/zimbra/data/ldap/mdb/db folder try to run:

    Code:
    /opt/zimbra/openldap/sbin/slapadd -q -b "" -F /opt/zimbra/data/ldap/config -cv -l /backup/ldap.bak
    It completes without error:

    Code:
    added: "cn=zimbra" (00000001)
    added: "cn=admins,cn=zimbra" (00000002)
    added: "uid=zimbra,cn=admins,cn=zimbra" (00000003)
    added: "uid=zmreplica,cn=admins,cn=zimbra" (00000004)
    added: "cn=appaccts,cn=zimbra" (00000005)
    added: "uid=zmnginx,cn=appaccts,cn=zimbra" (00000006)
    added: "uid=zmpostfix,cn=appaccts,cn=zimbra" (00000007)
    added: "uid=zmamavis,cn=appaccts,cn=zimbra" (00000008)
    added: "uid=zmbes-searcher,cn=appaccts,cn=zimbra" (00000009)
    added: "cn=zimlets,cn=zimbra" (0000000a)
    .........
    If i don't remove the 'data.mdb' file and run the command, i receive a whole bunch of Key/data pair already exists errors:

    Code:
    50dc4608 => mdb_tool_entry_put: txn_aborted! MDB_KEYEXIST: Key/data pair already exists (-30799)
    but then, users (including Admin) have no login access at all to the webclient or Admin Console (in the case of the admin user acc.) .

    I can't figure where I'm going wrong with the import of this LDAP data into Zimbra 8.0.2.?

    Have I made an error witht the initial import/transfer of the data.mdb database before LDAP import?
    Last edited by elijahpaul; 12-27-2012 at 06:43 AM.

  3. #3
    Join Date
    Jan 2011
    Posts
    19
    Rep Power
    4

    Default

    Managed to resolve this by deleting the existing data.mdb file and importing a backup ldap.bak file made before upgrading the old server from 7.2.0 > 8.0.2.

    Can now see all accounts in the Admin Console.

Similar Threads

  1. Zimbra FOSS to Network Edition
    By spectra in forum Installation
    Replies: 1
    Last Post: 02-01-2011, 03:29 PM
  2. Zimbra FOSS on Ubuntu
    By breejesh in forum Administrators
    Replies: 3
    Last Post: 12-22-2010, 04:35 AM
  3. Replies: 2
    Last Post: 07-23-2008, 09:25 AM
  4. Replies: 4
    Last Post: 07-18-2007, 04:51 PM
  5. Is it possible to upgrade from Zimbra FOSS to Network Edition?
    By greenrenault in forum Administrators
    Replies: 0
    Last Post: 10-19-2006, 06:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •