Results 1 to 1 of 1

Thread: Zimbra picks up wrong internal domain name but still uses external domain and works?

Hybrid View

  1. #1
    Join Date
    Jun 2011
    Posts
    76
    Rep Power
    4

    Default Zimbra picks up wrong internal domain name but still uses external domain and works?

    Hello everyone, I've just been messing around with installing Zimbra 7 on a Ubuntu machine and I came across something I have not seen before.

    These are my system files before I installed zimbra -

    hostname -
    Code:
    root@zimbra7:~# cat /etc/hostname
    zimbra7

    hosts -

    Code:
    root@zimbra7:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost zimbra7
    192.168.200.254 mail.wuboz.com mail zimbra7
    Resolv.conf
    Code:
    root@zimbra7:~# cat /etc/resolv.conf
    nameserver 127.0.0.1
    dnsmasq.conf -

    Code:
    server=8.8.8.8
    server=4.2.2.2
    domain=wuboz.com
    mx-host=wuboz.com,mail.wuboz.com,5
    listen-address=127.0.0.1
    Zimbra when installing detected the domain wuboz.com just fine, however when it was going through the install it latched on to the localhost.localdomain as something that I don't know how to refer to.

    All of my email address have the wuboz.com domain on them and I can send and receive emails fine through the internet. However in the Admin GUI and in the source emails it shows the localhost.localdomain -

    Here is the splash screen of the Zimbra admin console, it will show the localhost.localdomain


    However right here it shows the wuboz.com domain


    But under server statistics it shows the localhost.localdomain



    I have never seen it pick up the localhost domain, during the install I specifically stated wuboz.com and it took it just fine.

    Here is the dig of wuboz.com -

    Code:
    dig wuboz.com any
    
    ; <<>> DiG 9.7.0-P1 <<>> wuboz.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 10886
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;wuboz.com.                     IN      ANY
    
    ;; ANSWER SECTION:
    wuboz.com.              0       IN      MX      5 mail.wuboz.com.
    
    ;; ADDITIONAL SECTION:
    mail.wuboz.com.         0       IN      A       192.168.200.254
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Dec 31 22:19:40 2012
    ;; MSG SIZE  rcvd: 73
    If I do hostname -f I get localhost.localdomain

    In this scenario all of the SSL certificates are setup for localhostl.localdomain instead of wuboz.com.

    Can someone explain what happened?


    Is it because the zimbra7 hostname was behind 127.0.0.1?
    Last edited by Eclipse; 12-31-2012 at 09:40 PM.

Similar Threads

  1. Replies: 4
    Last Post: 11-15-2011, 09:56 AM
  2. Replies: 4
    Last Post: 07-29-2009, 08:24 PM
  3. Internal Access to External Domain Name
    By CharlieDavi in forum Administrators
    Replies: 4
    Last Post: 11-24-2008, 06:51 AM
  4. [SOLVED] Zimbra External/Internal Domain Question
    By jstlouis in forum Installation
    Replies: 2
    Last Post: 10-09-2008, 07:20 AM
  5. Internal + External Domain Questions
    By Markus23 in forum Installation
    Replies: 1
    Last Post: 01-22-2008, 11:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •