Results 1 to 6 of 6

Thread: Problem while copying sent mail to "Sent" folder --> TimeOut

Hybrid View

  1. #1
    Join Date
    Aug 2010
    Posts
    40
    Rep Power
    5

    Post Problem while copying sent mail to "Sent" folder --> TimeOut

    Hi,

    It seems that I have a strange problem with some users of my Zimbra mail server.

    It is happening randomly, and so, it's hard to diagnose.

    Basically, sometimes, when a user send a mail, the client (Thunderbid mainly, but seems to happen with Outlook too, but I'm not sure), the mail program copies the sent email to the "Sent" Folder, and it's just keeping hang on this step.

    The mail seems to be sent, but can't get copied to SentFolder and thunderbird stay stuck at "Copying message to Sent Items".

    While stuck on this screen, to resolve the issue, there are 2 solutions for the client :

    - Hitting "Cancel", and then hitting "Send" to re-send the mail. --> This time, the mail is sent again, and copied to the Sent folder without any problem/timeout.
    - While stuck on the screen "Copying to Sent Folder", going back to the Thunderbird Interface, and just select another folder (Junk, Trash, a sub-Inbox folder, etc...). I think while doing this, Thunderbird create another connection to the server, and then, the mail can be copied to sent item.

    I really don't know what could be the problem, my server is fine, and not under pressure.

    It has 4Vcpu (XEON 5600), 10GB RAM.

    I have 300 users on my mail server, with at high loads, about 200users connected at the same time, let's say 100 with web, 60 with IMAP, and 40 for POP3.

    Here is a revelent log when the problem happens :

    Code:
    2013-01-03 20:05:38,836 INFO  [ImapSSLServer-343] [] imap - [81.84.19.53] connected
    2013-01-03 20:05:39,594 INFO  [ImapSSLServer-343] [name=compte@company.com;ip=81.84.19.53;] imap - user compte@company.com authenticated, mechanism=PLAIN [TLS]
    2013-01-03 20:05:47,112 INFO  [ImapSSLServer-344] [] imap - [81.84.19.53] connected
    2013-01-03 20:05:47,876 INFO  [ImapSSLServer-344] [name=compte@company.com;ip=81.84.19.53;] imap - user compte@company.com authenticated, mechanism=PLAIN [TLS]
    2013-01-03 20:05:48,793 INFO  [ImapSSLServer-344] [name=compte@company.com;ip=81.84.19.53;ua=Thunderbird/17.0;] index - IndexDeferredItems(null, 68700): Deferred count out of sync - found=22 in progress=0 (deferred count=20)
    2013-01-03 20:05:49,010 INFO  [ImapSSLServer-344] [name=compte@company.com;ip=81.84.19.53;ua=Thunderbird/17.0;] index - Deferred Indexing: submitted 22 items in 218ms (100.92/sec). (0 items failed to index). IndexDeferredCount now at 22 NumNotSubmitted= 0
    2013-01-03 20:05:49,016 INFO  [ImapSSLServer-344] [name=compte@company.com;ip=81.84.19.53;ua=Thunderbird/17.0;] mailop - Adding Message: id=30407, Message-ID=<50E5D660.6000400@company.com>, parentId=-1, folderId=5, folderName=Sent.
    2013-01-03 20:06:31,667 INFO  [ImapSSLServer-336] [ip=81.84.19.53;] ProtocolHandler - I/O error while processing connection: java.net.SocketException: Connection timed out
    2013-01-03 20:06:31,672 INFO  [ImapSSLServer-336] [ip=81.84.19.53;] imap - dropping connection for user compte@company.com (server-initiated)
    2013-01-03 20:12:43,545 INFO  [ImapSSLServer-343] [name=compte@company.com;ip=81.84.19.53;ua=Thunderbird/17.0;] mailop - Adding Message: id=30409, Message-ID=<50E5D82F.4010805@company.com>, parentId=-1, folderId=5, folderName=Sent.
    2013-01-03 20:12:44,611 INFO  [ImapSSLServer-343] [name=compte@company.com;ip=81.84.19.53;ua=Thunderbird/17.0;] imap - dropping connection for user compte@company.com (LOGOUT)
    (IP and mails Changed)

    I think the problem appears here :

    2013-01-03 20:06:31,667 INFO [ImapSSLServer-336] [ip=81.84.19.53;] ProtocolHandler - I/O error while processing connection: java.net.SocketException: Connection timed out

    Also, I have the same message for POP3, so I assume it's also happening in POP3 mode :

    Here some of my settings :

    data_source_imap_reuse_connections = false
    imap_authenticated_max_idle_time = 1800
    imap_inactive_session_cache_size = 10000
    imap_max_idle_time = 60
    imap_max_request_size = 10240
    imap_use_ehcache = true
    javamail_imap_debug = false
    javamail_imap_enable_starttls = true
    javamail_imap_test_timeout = 20
    javamail_imap_timeout = 60
    zimbra_session_limit_imap = 50


    zimbra@mail:/$ zmlocalconfig | grep timeout
    cbpolicyd_bypass_timeout = 30
    cbpolicyd_timeout = 120
    cli_httpclient_soaphttptransport_so_timeout = 0
    httpclient_convertd_so_timeout = -1
    httpclient_external_client_connection_timeout = 30000
    httpclient_external_connmgr_connection_timeout = 25000
    httpclient_external_connmgr_idle_reaper_connection _timeout = 300000
    httpclient_external_connmgr_so_timeout = 60000
    httpclient_internal_client_connection_timeout = 30000
    httpclient_internal_connmgr_connection_timeout = 25000
    httpclient_internal_connmgr_idle_reaper_connection _timeout = 300000
    httpclient_internal_connmgr_so_timeout = 60000
    httpclient_soaphttptransport_so_timeout = 300000
    javamail_imap_test_timeout = 20
    javamail_imap_timeout = 60
    javamail_pop3_test_timeout = 20
    javamail_pop3_timeout = 60
    javamail_smtp_timeout = 60
    ldap_common_writetimeout = 0
    ldap_connect_pool_timeout = 120000
    ldap_connect_timeout = 30000
    ldap_read_timeout = 0
    milter_write_timeout = 10
    socket_connect_timeout = 30000
    socket_so_timeout = 30000
    xmpp_client_idle_timeout = 600000
    xmpp_client_write_timeout = 60000
    xmpp_cloudrouting_idle_timeout = 300000
    xmpp_muc_idle_user_timeout_ms = 0
    xmpp_server_read_timeout = 180000
    zimbra_admin_waitset_default_request_timeout = 300
    zimbra_admin_waitset_max_request_timeout = 3600
    zimbra_admin_waitset_min_request_timeout = 0
    zimbra_archive_formatter_disable_timeout = true
    zimbra_gal_sync_disable_timeout = true
    zimbra_noop_default_timeout = 300
    zimbra_noop_max_timeout = 1200
    zimbra_noop_min_timeout = 30
    zimbra_session_timeout_soap = 600
    zimbra_waitset_default_request_timeout = 300
    zimbra_waitset_max_request_timeout = 1200
    zimbra_waitset_min_request_timeout = 30

    Don't really know what should I tweak to correct this...

  2. #2
    Join Date
    Aug 2010
    Posts
    40
    Rep Power
    5

    Default

    Nobody facing this problem ?

  3. #3
    Join Date
    Aug 2010
    Posts
    40
    Rep Power
    5

    Default

    Also catching this message in mailbox.log, don't know if it's related :

    2013-01-10 05:56:53,816 INFO [btpool0-48://127.0.0.1/zimbra/h/search?si=6&so=0&sc=15&st=message&id=9562&paction= view&action=compose&rf=html&op=reply] [] HttpMethodDirector - I/O exception (org.apache.commons.httpclient.NoHttpResponseExcep tion) caught when processing request: The server localhost failed to respond

    (IP Changed to 127.0.0.1, otherwise it's my public zimbra ip).

    Please I really need advices/help, I have a lot of users complaining about my Zimbra

  4. #4
    Join Date
    Aug 2010
    Posts
    40
    Rep Power
    5

    Default

    Catching another error :

    imap - skipping error while trying to page in for copy (INBOX)

  5. #5
    Join Date
    Jul 2013
    Posts
    1
    Rep Power
    2

    Default

    Hi nameless', were you able to fix this? We have exactly the same issue. We are running 7.2.0 now and we want to update to 7.2.4 or 8.0.x, maybe that resolves the issue.

    It appears to us not all users are experiencing this, but some are...
    Last edited by kolkmvd; 07-26-2013 at 02:00 AM.

  6. #6
    Join Date
    Aug 2010
    Posts
    40
    Rep Power
    5

    Default

    Hi,
    No, I am with Zimbra 7.2.3 and I still have the same problem from time to time.
    I just read yesterday that if you are using TLS that might be the problem, and can be resolved by switching to SSL.
    I told this to one of my user that has the problem yesterday, I am waiting for his feedback.
    But I think it's happening less often with the latest updates.

Similar Threads

  1. Replies: 2
    Last Post: 07-20-2013, 11:45 AM
  2. Replies: 3
    Last Post: 04-02-2012, 10:06 AM
  3. Replies: 30
    Last Post: 12-09-2010, 05:25 AM
  4. Replies: 5
    Last Post: 10-07-2010, 06:50 AM
  5. Changing "unable to deliver mail" timeout setting
    By KLGNT in forum Administrators
    Replies: 3
    Last Post: 09-14-2010, 11:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •