Results 1 to 10 of 13

Thread: SMTP Trouble

Hybrid View

  1. #1
    Join Date
    Jul 2009
    Location
    Houston, TX
    Posts
    22
    Rep Power
    6

    Default SMTP Trouble

    I just started getting this message yesterday on a server that has been running fine for years, to my knowledge nothing has changed on the Ubuntu server recently and the Zimbra version has been stable also for a while (8.0.2 network). Only thing possible is some network provider changes (ATT). All of my users are seeing this when they try to send an email:

    This is the mail system at host mail.cbrworld.com.

    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to postmaster.

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The mail system

    <xxxxxxx@mac.com>: host 127.0.0.1[127.0.0.1] said: 504 5.5.2 id=03268-01 -
    Rejected by next-hop MTA on relaying, from MTA(smtp:[127.0.0.1]:10029): 504
    5.5.2 <localhost>: Helo command rejected: need fully-qualified hostname (in
    reply to end of DATA command)
    "Hostname -f" shows the correct name (mail.cbrworld.com) and "postconf | grep myhostname" returns same. Any help in where I should start looking would be appreciated.
    Release 8.0.2.GA.5569.UBUNTU12.64 UBUNTU12_64 NETWORK edition

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Take your pick of these solutions: +"Helo command rejected: need fully-qualified hostname" - Yahoo! Search Results and your server also doesn't have a valid reverse DNS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2009
    Location
    Houston, TX
    Posts
    22
    Rep Power
    6

    Default

    According to a couple of the threads listed, this should be correct:

    root@mail:~# hostname -f
    mail.cbrworld.com
    root@mail:~# su - zimbra
    zimbra@mail:~$ postconf | grep myhostname
    lmtp_lhlo_name = $myhostname
    local_transport = local:$myhostname
    milter_macro_daemon_name = $myhostname
    myhostname = mail.cbrworld.com
    myorigin = $myhostname
    smtp_helo_name = $myhostname
    smtpd_banner = $myhostname ESMTP $mail_name
    smtpd_proxy_ehlo = $myhostname
    zimbra@mail:~$ postconf -n
    alias_maps = hash:/etc/aliases
    always_add_missing_headers = yes
    bounce_notice_recipient = postmaster
    bounce_queue_lifetime = 5d
    broken_sasl_auth_clients = yes
    command_directory = /opt/zimbra/postfix/sbin
    config_directory = /opt/zimbra/postfix-2.10-20121007.2z/conf
    content_filter = smtp-amavis:[127.0.0.1]:10024
    daemon_directory = /opt/zimbra/postfix/libexec
    delay_warning_time = 0h
    disable_dns_lookups = no
    header_checks =
    import_environment =
    in_flow_delay = 1s
    inet_protocols = ipv4
    lmtp_connection_cache_destinations =
    lmtp_connection_cache_time_limit = 4s
    lmtp_host_lookup = dns
    local_header_rewrite_clients = permit_mynetworks,permit_sasl_authenticated
    mail_owner = postfix
    mailbox_size_limit = 0
    mailq_path = /opt/zimbra/postfix/sbin/mailq
    manpage_directory = /opt/zimbra/postfix/man
    maximal_backoff_time = 4000s
    message_size_limit = 102400000
    minimal_backoff_time = 300s
    mydestination = localhost
    myhostname = mail.cbrworld.com
    mynetworks = 127.0.0.0/8 75.63.111.40/29 [::1]/128
    newaliases_path = /opt/zimbra/postfix/sbin/newaliases
    non_smtpd_milters =
    notify_classes = resource,software
    propagate_unmatched_extensions = canonical
    queue_directory = /opt/zimbra/data/postfix/spool
    queue_run_delay = 300s
    recipient_delimiter =
    relayhost =
    sender_canonical_maps = proxy:ldap:/opt/zimbra/conf/ldap-scm.cf
    sendmail_path = /opt/zimbra/postfix/sbin/sendmail
    setgid_group = postdrop
    smtp_cname_overrides_servername = no
    smtp_sasl_auth_enable = no
    smtp_sasl_mechanism_filter =
    smtp_sasl_password_maps =
    smtp_sasl_security_options = noplaintext,noanonymous
    smtp_tls_security_level =
    smtpd_client_restrictions = reject_unauth_pipelining
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_end_of_data_restrictions =
    smtpd_helo_required = yes
    smtpd_milters =
    smtpd_recipient_restrictions = reject_non_fqdn_recipient, reject_unlisted_recipient, reject_invalid_helo_hostname, reject_non_fqdn_helo_hostname, reject_non_fqdn_sender, reject_unknown_client_hostname, reject_unknown_helo_hostname, reject_unknown_sender_domain, reject_rbl_client zen.spamhaus.org reject_rbl_client b.barracudacentral.org, permit
    smtpd_reject_unlisted_recipient = no
    smtpd_relay_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_authenticated_header = no
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_tls_security_options = $smtpd_sasl_security_options
    smtpd_sender_restrictions = check_sender_access regexp:/opt/zimbra/postfix/conf/tag_as_originating.re, permit_mynetworks, permit_sasl_authenticated, permit_tls_clientcerts, check_sender_access regexp:/opt/zimbra/postfix/conf/tag_as_foreign.re
    smtpd_tls_auth_only = yes
    smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
    smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
    smtpd_tls_loglevel = 1
    smtpd_tls_security_level = may
    transport_maps = proxy:ldap:/opt/zimbra/conf/ldap-transport.cf
    virtual_alias_domains = proxy:ldap:/opt/zimbra/conf/ldap-vad.cf
    virtual_alias_expansion_limit = 10000
    virtual_alias_maps = proxy:ldap:/opt/zimbra/conf/ldap-vam.cf
    virtual_mailbox_domains = proxy:ldap:/opt/zimbra/conf/ldap-vmd.cf
    virtual_mailbox_maps = proxy:ldap:/opt/zimbra/conf/ldap-vmm.cf
    virtual_transport = error
    Unfortunately GoDaddy's DNS doesn't support reverse DNS...
    Release 8.0.2.GA.5569.UBUNTU12.64 UBUNTU12_64 NETWORK edition

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by cwall64 View Post
    According to a couple of the threads listed, this should be correct:
    I'm afraid your pout shows nothing except the configuration options, you need to see what the helo response is.

    Quote Originally Posted by cwall64 View Post
    Unfortunately GoDaddy's DNS doesn't support reverse DNS...
    Of course it doesn't a reverse DNS is supplied by your ISP not the DNS host for your records.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Jul 2009
    Location
    Houston, TX
    Posts
    22
    Rep Power
    6

    Default

    Is this the HELO that we are looking for:
    Christophers-MBP-266:~ cwall$ telnet mail.cbrworld.com 25
    Trying 75.63.111.42...
    Connected to mail.cbrworld.com.
    Escape character is '^]'.
    220 mail.cbrworld.com ESMTP Postfix
    helo
    501 Syntax: HELO hostname
    helo mail.cbrworld.com
    250 mail.cbrworld.com
    Release 8.0.2.GA.5569.UBUNTU12.64 UBUNTU12_64 NETWORK edition

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by cwall64 View Post
    Is this the HELO that we are looking for:
    Yes and it's correct but as I mentioned it doesn't have a valid reverse DNS.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Forcing SMTP TLS connection with other SMTP Servers
    By Meaulnes in forum Administrators
    Replies: 3
    Last Post: 12-07-2011, 09:38 AM
  2. Replies: 2
    Last Post: 06-20-2011, 01:31 PM
  3. Replies: 0
    Last Post: 09-13-2009, 04:56 AM
  4. Replies: 1
    Last Post: 05-27-2009, 01:07 PM
  5. Replies: 2
    Last Post: 10-10-2006, 12:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •