Results 1 to 5 of 5

Thread: UBUNTU upgrade and Zimbra is down

Hybrid View

  1. #1
    Join Date
    Dec 2010
    Posts
    13
    Rep Power
    5

    Default UBUNTU upgrade and Zimbra is down

    Dear All,

    I am in urgent need of help.

    I'm running:
    Ubuntu Lucid Lynx 10.04.1 LTS
    Zimbra 6.0.9 GA Release (6.0.9_GA_2686_UBUNTU10_64)

    but I have just upgraded Ubuntu to the latest version:
    Distributor ID: Ubuntu
    Description: Ubuntu 12.04.2 LTS
    Release: 12.04
    Codename: precise

    After the Ubuntu upgrade my current production Zimbra server cannot function at all... I really do not know what to do now.
    I run the command:
    zimbra@mail:~$ zmcontrol status
    Use of qw(...) as parentheses is deprecated at /opt/zimbra/zimbramon/lib/Zimbra/Util/Common.pm line 25.
    Use of qw(...) as parentheses is deprecated at /opt/zimbra/zimbramon/lib/Zimbra/Util/Common.pm line 26.
    /usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Gthr_key_ptr

    I have downloaded the latest version of Zimbra to try to solve this issue but it is still not working.
    wget http://files2.zimbra.com/downloads/7...1204211915.tgz
    tar -zxvf zcs-7.2.2_GA_2852.UBUNTU10_64.20121204211915.tgz
    cd zcs-7.2.2_GA_2852.UBUNTU10_64.20121204211915
    ./install.sh

    Error shows:
    Do you want to verify message store database integrity? [Y] y
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Verifying integrity of message store databases. This may take a while.
    Starting mysqld...done.
    mysqld is alive
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Gthr_key_ptr
    mysqld is alive
    Stopping mysqld... done.

    Please please help me, I'm running a production server and I have absolutely no clue what I should do next.

    Thank you.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You just upgraded your operating system to an unsupported version of Ubuntu, why in heavens name did you do that? Tell me that you had a backup of your /opt/zimbra directory structure and you know how to restore it?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Dec 2010
    Posts
    13
    Rep Power
    5

    Default

    Hi Bill,

    Thank you for the response, I was worried on any security issues as everytime I logged in it asked me to do do apt upgrade.

    My /opt/zimbra directory structure is still there, and no I did not do a backup.

    Could you log in and have a look for me please?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You need to take a copy of the /opt/zimbra directory structure (is it also on the root partition of your HD?), use one of the backup methods is the wiki. If the zimbra directory is on your root HD then copy the backup somewhere safe on another machine. At this point, the only version of ZCS that runs on Ubuntu 12.04 is ZCS 8.x, you could download that and try an upgrade (I'm not advising that but it's one option for you to consider).

    Have you got a local copy of your ZCS install file, if not then get the exact same version from the archive page (via the Download page at the top of this page) and you'll also need to reinstall the same version of Ubuntu that was previously installed - make sure you have the /opt/zimbra backup somewhere safe as an operating system will overwrite your root partition (I'm sure you know this already but it bears repeating). You can take a look at this article that detail steps for (backing up and) restoring your ZCS. I believe there are also some threads in the forums where people have performed the same upgrade as you've just done and had to recover their installation, I think that a couple of them were successful so have a search for them.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Dec 2010
    Posts
    13
    Rep Power
    5

    Default

    Hi Bill,

    Thank you for the advise. Things start to go wrong when we start to panic. I'm glad that you are around to give us advise and point us in the right direction. I realised as well that the version i need to download is the ZCS 8.X, I have tried to upgrade with this version but it failed as below:


    Do you want to verify message store database integrity? [Y] y
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    Verifying integrity of message store databases. This may take a while.
    Starting mysqld...done.
    mysqld is alive
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Gthr_key_ptr
    mysqld is alive
    Stopping mysqld... done.


    I then read online on another forum post that there may be a chance to install, by skipping the integrity check, it went as far as below and then stopped:
    Do you want to verify message store database integrity? [Y] n
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 5090 package 'zimbra-ldap':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 6455 package 'zimbra-logger':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 7321 package 'zimbra-apache':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8382 package 'zimbra-mta':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8679 package 'zimbra-core':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8823 package 'zimbra-spell':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 9022 package 'zimbra-snmp':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 12197 package 'zimbra-store':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell
    Found zimbra-memcached
    Found zimbra-proxy


    The Zimbra Collaboration Server appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.

    Do you wish to upgrade? [Y] y
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LC_CTYPE = "UTF-8",
    LANG = "en_US.UTF-8"
    are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 5090 package 'zimbra-ldap':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 6455 package 'zimbra-logger':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 7321 package 'zimbra-apache':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8382 package 'zimbra-mta':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8679 package 'zimbra-core':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8823 package 'zimbra-spell':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 9022 package 'zimbra-snmp':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 12197 package 'zimbra-store':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number

    Select the packages to install
    Upgrading zimbra-core
    Upgrading zimbra-ldap
    Upgrading zimbra-logger
    Upgrading zimbra-mta
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 5090 package 'zimbra-ldap':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 6455 package 'zimbra-logger':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 7321 package 'zimbra-apache':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8382 package 'zimbra-mta':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8679 package 'zimbra-core':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8823 package 'zimbra-spell':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 9022 package 'zimbra-snmp':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 12197 package 'zimbra-store':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 4148 package 'zimbra-proxy':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 5373 package 'zimbra-ldap':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 6727 package 'zimbra-logger':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 7609 package 'zimbra-apache':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 8454 package 'zimbra-mta':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 8769 package 'zimbra-core':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 9074 package 'zimbra-spell':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 9272 package 'zimbra-snmp':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 10604 package 'zimbra-memcached':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/available' near line 12391 package 'zimbra-store':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 5090 package 'zimbra-ldap':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 6455 package 'zimbra-logger':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 7321 package 'zimbra-apache':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8382 package 'zimbra-mta':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8679 package 'zimbra-core':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 8823 package 'zimbra-spell':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 9022 package 'zimbra-snmp':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 12197 package 'zimbra-store':
    error in Version string '6.0.9_GA_2686.UBUNTU10_64': invalid character in version number
    Conflicting package: postfix

    ###ERROR###

    One or more package conflicts exists.
    Please remove them before running this installer.

    Installation cancelled.



    So it looks like I will need to backup up the /opt/zimbra to another machine and do a fresh install of Ubuntu Lucid Lynx 10.04.1 LTS, and then reconfigure network settings and bind, then transfer back the /opt/zimbra and reinstall Zimbra 6.0.9 GA Release (6.0.9_GA_2686_UBUNTU10_64)

    I'm currently waiting for access to another server to do the backup...

    Thank you so much for the advise Bill, will post back to update everyone on the issue.

Similar Threads

  1. Zimbra-Upgrade and Server-Move inkl. Ubuntu-Dist-Upgrade
    By karl.kowald in forum Administrators
    Replies: 5
    Last Post: 10-25-2011, 11:24 AM
  2. Upgrade Ubuntu 6.06LTS to Ubuntu 8.04LTS and Zimbra 6.x
    By ajaylamb in forum Administrators
    Replies: 3
    Last Post: 09-12-2011, 02:45 AM
  3. Zimbra Upgrade: Ubuntu 8 vs 10
    By bhwong in forum Administrators
    Replies: 3
    Last Post: 06-22-2011, 08:54 PM
  4. Zimbra Upgrade: Ubuntu 8 vs 10
    By bhwong in forum Installation
    Replies: 0
    Last Post: 06-21-2011, 08:14 PM
  5. Upgrade from Ubuntu 6.06 and Zimbra to Ubuntu 8.0
    By JoeLosco in forum Administrators
    Replies: 0
    Last Post: 08-20-2008, 09:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •