Dear All,

I am in urgent need of help.

I'm running:
Ubuntu Lucid Lynx 10.04.1 LTS
Zimbra 6.0.9 GA Release (6.0.9_GA_2686_UBUNTU10_64)

but I have just upgraded Ubuntu to the latest version:
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

After the Ubuntu upgrade my current production Zimbra server cannot function at all... I really do not know what to do now.
I run the command:
zimbra@mail:~$ zmcontrol status
Use of qw(...) as parentheses is deprecated at /opt/zimbra/zimbramon/lib/Zimbra/Util/Common.pm line 25.
Use of qw(...) as parentheses is deprecated at /opt/zimbra/zimbramon/lib/Zimbra/Util/Common.pm line 26.
/usr/bin/perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Gthr_key_ptr

I have downloaded the latest version of Zimbra to try to solve this issue but it is still not working.
wget http://files2.zimbra.com/downloads/7...1204211915.tgz
tar -zxvf zcs-7.2.2_GA_2852.UBUNTU10_64.20121204211915.tgz
cd zcs-7.2.2_GA_2852.UBUNTU10_64.20121204211915
./install.sh

Error shows:
Do you want to verify message store database integrity? [Y] y
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Verifying integrity of message store databases. This may take a while.
Starting mysqld...done.
mysqld is alive
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Data/UUID/UUID.so: undefined symbol: Perl_Gthr_key_ptr
mysqld is alive
Stopping mysqld... done.

Please please help me, I'm running a production server and I have absolutely no clue what I should do next.

Thank you.