Hello everyone,

I'm having deferred mails for a number of domains (cannot mention them here), while outgoing mails to other domains, for eg, gmail.com is working.
NB: Everything was working fine since a number of weeks (since I upgraded to Zimbra ZCS 8.0.2).

Below is an extract of /var/log/zimbra.log:

Code:
Feb 15 20:40:13 postman postfix/smtp[38259]: A28166C54B7: to=<user1@diadeis.com>, relay=mail.domain.com[A.B.C.D]:25, delay=10284, delays=9983/0.01/0.85/300, dsn=4.4.2, status=deferred (host mail.domain.com[A.B.C.D] said: 421 4.4.2 mail2.domain.com Error: timeout exceeded (in reply to end of DATA command))
Feb 15 20:45:12 postman postfix/error[43182]: AC9E86C549D: to=<user2@domain.com>, relay=none, delay=10576, delays=10576/0.01/0/0.01, dsn=4.4.2, status=deferred (delivery temporarily suspended: conversation with mail.domain.com[A.B.C.D] timed out while sending message body)
If I telnet to mail.domain.com on port 25 from the mail server itself and then issue SMTP commands manually, the mail is sent successfully.
So, I suppose the problem is probably with Zimbra's configuration.

Below are details of the Zimbra server network configuration:

host `hostname`:
Code:
[root@postman ~]# host `hostname`
postman.mydomain.com has address 10.0.0.120
/etc/hosts:
Code:
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
#10.0.0.6       messenger.mydomain.lan messenger
10.0.0.120      postman.mydomain.com postman
/etc/resolv.conf:
Code:
nameserver 10.0.0.32
nameserver 10.0.0.33
search mydomain.lan
dig mydomain.com MX:
Code:
[root@postman ~]# dig mydomain.com mx

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.6 <<>> mydomain.com mx
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38083
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;mydomain.com.                    IN      MX

;; ANSWER SECTION:
mydomain.com.             3600    IN      MX      10 postman.mydomain.com.

;; ADDITIONAL SECTION:
postman.mydomain.com.     3600    IN      A       10.0.0.120

;; Query time: 0 msec
;; SERVER: 10.0.0.32#53(10.0.0.32)
;; WHEN: Fri Feb 15 20:57:40 2013
;; MSG SIZE  rcvd: 68
dig mydomain.com any:
Code:
[root@postman ~]# dig mydomain.com any

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.6 <<>> mydomain.com any
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1058
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 4

;; QUESTION SECTION:
;mydomain.com.                    IN      ANY

;; ANSWER SECTION:
mydomain.com.             3600    IN      NS      nickel.mydomain.lan.
mydomain.com.             3600    IN      NS      neon.mydomain.lan.
mydomain.com.             3600    IN      SOA     nickel.mydomain.lan. hostmaster.mydomain.lan. 45 900 600 86400 3600
mydomain.com.             3600    IN      MX      10 postman.mydomain.com.

;; ADDITIONAL SECTION:
nickel.mydomain.lan.   3600    IN      A       10.0.0.32
nickel.mydomain.lan.   3600    IN      A       10.6.0.32
neon.mydomain.lan.     3600    IN      A       10.6.0.33
postman.mydomain.mu.     3600    IN      A       10.0.0.120

;; Query time: 0 msec
;; SERVER: 10.0.0.32#53(10.0.0.32)
;; WHEN: Fri Feb 15 20:58:52 2013
;; MSG SIZE  rcvd: 216
Any help is much appreciated.

Thanks in advance.