Hi,

I have Zimbra server installed and with the ZIMBRA desktop everything seems to be working fine (sending / receiving email).

Now I try to setup my Thunderbird to connect to the ZIMBRA server via IMAP (993) and SMTP (465).

Receiving email via IMAP (port 993) is working fine. But I can't send an email with thunderbird via the SMTP Secure port (465).

The logs show the following error:



Mar 12 11:40:36 server003 postfix/smtpd[15798]: connect from unknown[217.169.232.184]
Mar 12 11:40:36 server003 postfix/smtpd[15798]: setting up TLS connection from unknown[217.169.232.184]
Mar 12 11:40:36 server003 postfix/smtpd[15798]: unknown[217.169.232.184]: TLS cipher list "aNULL:-aNULL:ALL:!EXPORT:!LOW:+RC4:@STRENGTH"
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:before/accept initialization
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 read client hello A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 write server hello A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 write certificate A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 write key exchange A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 write server done A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 flush data
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 read client key exchange A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 read finished A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 write session ticket A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 write change cipher spec A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 write finished A
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL_accept:SSLv3 flush data
Mar 12 11:40:36 server003 postfix/smtpd[15798]: Anonymous TLS connection established from unknown[217.169.232.184]: TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits)
Mar 12 11:40:36 server003 postfix/smtpd[15798]: SSL3 alert read:fatal:unknown CA
Mar 12 11:40:36 server003 postfix/smtpd[15798]: warning: TLS library problem: 15798:error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1251:SSL alert number 48:
Mar 12 11:40:36 server003 postfix/smtpd[15798]: lost connection after CONNECT from unknown[217.169.232.184]
Mar 12 11:40:36 server003 postfix/smtpd[15798]: disconnect from unknown[217.169.232.184]



My smtp / tls settings (zmlocalconfig),

[U]zmlocalconfig | grep -i tls[/U]
debug_xmpp_disable_client_tls = 0
javamail_imap_enable_starttls = true
javamail_pop3_enable_starttls = true
javamail_smtp_enable_starttls = true
ldap_common_require_tls = 0
ldap_starttls_required = true
ldap_starttls_supported = 1
postfix_smtpd_sasl_tls_security_options = $smtpd_sasl_security_options
postfix_smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
postfix_smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
postfix_smtpd_tls_loglevel = 2
smtp_tls_CAfile = /opt/zimbra/conf/ca/ca.pem
xmpp_server_tls_enabled = true

zmlocalconfig | grep -i smtp
javamail_smtp_debug = false
javamail_smtp_enable_starttls = true
javamail_smtp_timeout = 60
javamail_zsmtp = true
postfix_enable_smtpd_policyd = no
postfix_smtp_cname_overrides_servername = no
postfix_smtp_sasl_auth_enable = no
postfix_smtp_sasl_security_options = noplaintext,noanonymous
postfix_smtpd_client_restrictions = reject_unauth_pipelining
postfix_smtpd_data_restrictions = reject_unauth_pipelining
postfix_smtpd_helo_required = yes
postfix_smtpd_sasl_authenticated_header = no
postfix_smtpd_sasl_security_options = noanonymous
postfix_smtpd_sasl_tls_security_options = $smtpd_sasl_security_options
postfix_smtpd_tls_cert_file = /opt/zimbra/conf/smtpd.crt
postfix_smtpd_tls_key_file = /opt/zimbra/conf/smtpd.key
postfix_smtpd_tls_loglevel = 2
sasl_smtpd_mech_list = PLAIN LOGIN
smtp_destination = <...>
smtp_host_retry_millis = 60000
smtp_notify = yes
smtp_source = <...>
smtp_tls_CAfile = /opt/zimbra/conf/ca/ca.pem
smtp_to_lmtp_enabled = false
smtp_to_lmtp_port = 7024


Any help will be appreciated.