Results 1 to 4 of 4

Thread: Upgrade 8.0.2 -> 8.0.3 failed: Failed to start slapd

Hybrid View

  1. #1
    Join Date
    Mar 2013
    Posts
    2
    Rep Power
    2

    Question Upgrade 8.0.2 -> 8.0.3 failed: Failed to start slapd

    Hello, dear Zimbra gurus

    Tried to update 8.0.2 to 8.0.3 today, and upgrade failed: I can't run Zimbra anymore, getting:
    Code:
    	Starting ldap...Done.
    Failed.
    Failed to start slapd.  Attempting debug start to determine error.
    5143ac4d backend_startup_one (type=mdb, suffix=""): bi_db_open failed! (80)
    Tried to check logs:
    Code:
    Mar 16 00:15:55 www slapd[20580]: @(#) $OpenLDAP: slapd 2.4.33 (Feb 21 2013 10:49:23) $#012#011root@zre-ubuntu12-64:/home/build/p4/zimbra/main/ThirdParty/openldap/openldap-2.4.33.4z/servers/slapd
    Mar 16 00:15:55 www slapd[20580]: mdb_db_open: database "": DN index needs upgrade, run "slapindex entryDN".
    Mar 16 00:15:56 www slapd[20580]: backend_startup_one (type=mdb, suffix=""): bi_db_open failed! (80)
    Mar 16 00:15:56 www slapd[20580]: DIGEST-MD5 common mech free
    Mar 16 00:15:56 www slapd[20580]: slapd stopped.
    Tried to recover mdb:
    Code:
    zimbra@www:~/data/ldap/mdb/db$ db_recover -v
    BDB2526 Finding last valid log LSN: file: 1 offset 28
    zimbra@www:~/data/ldap/mdb/db$ ls
    Does it mean that database is ok?

    Tried to run suggested slapindex entryDN:
    Code:
    zimbra@www:~$ /opt/zimbra/openldap-2.4.33.4z/sbin/slapindex entryDN
    Unrecognized database type (bdb)
    5143accd /opt/zimbra/openldap-2.4.33.4z/etc/openldap/slapd.conf: line 53: <database> failed init (bdb)
    slapindex: bad configuration file!
    Tried to fix permission, no luck either.
    Any ideas how to resolve the issue?

  2. #2
    Join Date
    Nov 2012
    Posts
    26
    Rep Power
    2

    Default

    it is strange ..because update zimbra 8.0.2 to 8.0.3 with any problem at all.
    try to use

    /opt/zimbra/libexec/zmfixperms --verbose --extended
    su zimbra
    zmcontrol restart
    zmcontrol status
    also what kind os did you run ?
    did you check split dns ?
    regards

  3. #3
    Join Date
    Mar 2013
    Posts
    2
    Rep Power
    2

    Default

    /opt/zimbra/openldap-2.4.33.4z/sbin/slapindex -F /opt/zimbra/data/ldap/config entryDN

    This is what helped me.
    Thanks.

  4. #4
    Join Date
    Nov 2012
    Location
    Bangalore
    Posts
    173
    Rep Power
    2

    Default

    Thanks For Sharing..

Similar Threads

  1. Replies: 1
    Last Post: 10-10-2012, 05:43 AM
  2. Failed to start slapd.
    By rapharjm in forum Administrators
    Replies: 3
    Last Post: 04-27-2012, 12:03 PM
  3. Failed to start slapd.
    By rapharjm in forum Error Reports
    Replies: 1
    Last Post: 04-27-2012, 11:37 AM
  4. Failed to start slapd
    By skot999 in forum Administrators
    Replies: 1
    Last Post: 10-13-2011, 12:39 AM
  5. [SOLVED] Failed to start slapd.
    By Shalva77 in forum Administrators
    Replies: 2
    Last Post: 05-28-2011, 05:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •