Hello,

I'm trying to test the upgrade of a Zimbra NE :
- from Zimbra NE 7.2.0 on Ubuntu 8.04 LTS (same as my real production server)
- to Zimbra NE 8.x on Ubuntu 10.04 LTS
This upgrade is a simulation on local VM, in order to test it.

But I'm facing a weird problem :
"ERROR: Unable to reach the Zimbra License Activation Server."
with my trial licence on my test VM.

Overview of the process :
- Having a runing zimbra 7 / ubuntu 8 : works ok (verified)
- Upgrading the OS : Ubuntu 8 -> Ubuntu 10.04 LTS
(stopping zimbra + preventing it form starting at boot time, at first)
reboot : ubuntu works ok (zimbra shut down)
- Reinstalling Zimbra (same v7) for Ubuntu 10
... this is where all goes wrong

- Upgrading running Zimbra v7 to last v8
(not tested)

What goes wrong on step "Reinstalling Zimbra (same v7) for Ubuntu 10" :

Doing it as a "disaster recovery" :
- moving /opt/zimbra/ to /opt/zimbra-original/ to preserve datas
- doing a first "softwareonly" install
... this goes wrong, I stop here <------------

(- moving new /opt/zimbra/ to /opt/zimbra-bad/)
(- moving back /opt/zimbra-original/ to /opt/zimbra/ for preserved data)
(- modifying permissions :
$ chown -R zimbra:zimbra /opt/zimbra
$ /opt/zimbra/libexec/zmfixperms --verbose --extended)
(- doing real upgrade with new install for ubuntu 10 :
./install.sh --license /home/michel/ZCSLicense.xml)

When trying to do a first "softwareonly" install :
---------------------
root@xxxx:/tmp/zcs-NETWORK-7.2.0_GA_2669.UBUNTU10_64.20120410002323# ./install.sh -s --license /home/michel/ZCSLicense.xml

Operations logged to /tmp/install.log.1208
Checking for existing installation...
zimbra-ldap...FOUND zimbra-ldap-7.2.0_GA_2669.UBUNTU8_64
zimbra-logger...FOUND zimbra-logger-7.2.0_GA_2669.UBUNTU8_64
zimbra-mta...FOUND zimbra-mta-7.2.0_GA_2669.UBUNTU8_64
zimbra-snmp...FOUND zimbra-snmp-7.2.0_GA_2669.UBUNTU8_64
zimbra-store...FOUND zimbra-store-7.2.0_GA_2669.UBUNTU8_64
zimbra-apache...FOUND zimbra-apache-7.2.0_GA_2669.UBUNTU8_64
zimbra-spell...FOUND zimbra-spell-7.2.0_GA_2669.UBUNTU8_64
zimbra-convertd...FOUND zimbra-convertd-7.2.0_GA_2669.UBUNTU8_64
zimbra-memcached...NOT FOUND
zimbra-proxy...NOT FOUND
zimbra-archiving...NOT FOUND
zimbra-cluster...NOT FOUND
zimbra-core...FOUND zimbra-core-7.2.0_GA_2669.UBUNTU8_64
ZCS upgrade from 7.2.0 to 7.2.0 will be performed.
ERROR: Unable to reach the Zimbra License Activation Server.

License Activation is required when upgrading to ZCS 7 or later.

The ZCS Network upgrade will automatically attempt to activate the
current license as long as the activation server can be contacted.

You can obtain a manual activation key and re-run the upgrade
by specifying the -a activation.xml option.

A manual license activation key can be obtained by either visiting
the Zimbra support portal or contacting Zimbra support or sales.

root@xxxx:/tmp/zcs-NETWORK-7.2.0_GA_2669.UBUNTU10_64.20120410002323#
---------------------

....

Checking activation server :
$ wget https://license.zimbra.com/zimbraLic...on?action=test
it gives me :
"You've reached Zimbra activation server successfully."
which seems ok.

I have requested a new trial licence key, and tried it, but with the same error.

The weird thing is when I try to do the same softwareonly install on my "source" server (ubuntu 8, VM for tests),
(simulating a reinstall of the same zimbra), this error does not reach and the process continues OK
(I stop it before really modifying the system).

Any idea why this do not work ?

I have asked, the support but wating for them.