Results 1 to 4 of 4

Thread: Zimbra NE 8 zmrestore not working

  1. #1
    Join Date
    Aug 2012
    Rep Power

    Default [SOLVED] Zimbra NE 8 zmrestore not working


    I'm testing backup/restore before going production with a server. I deleted months of email from my mailbox ("oops"). When restoring my mailbox, the zmrestore seems to work, and there are a lot of messages like this in mailbox.log:

    2013-05-08 07:36:58,303 INFO  [qtp390087669-11799:] [name=...;mid=3;ip=;ua=zmrestore/8.0.2_GA_5569;] purge - Purging messages.
    2013-05-08 07:36:58,313 INFO  [qtp390087669-11799:] [name=...;mid=3;ip=;ua=zmrestore/8.0.2_GA_5569;] mailop - Adding Message: id=5475, Message-ID=<...>, parentId=-1, folderId=2, folderName=Inbox.
    However, when I look in the web client, I don't see any restored messages. The latest message is the one from after I deleted them.

    Did the restore fail? There are no errors that I can find.

    Is there something I need to do to make the messages appear in the web client?

    Last edited by jce; 05-09-2013 at 06:17 AM.

  2. #2
    Join Date
    May 2007
    Rep Power


    You may need to log in/out, or the restore is from after the emails are already in the dumpster. Please also check over Ajcody-Backup-Restore-Issues - Zimbra :: Wiki
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    Join Date
    Aug 2012
    Rep Power


    Thanks for the response. I've tried logging in and out, and I've tried restoring while logged in and logged out, but it makes no difference. The restore isn't from after the files were deleted--I deleted them only seconds before I did the restore and we do a nightly backup right now (the default). I'm not specifying a point in time to which it should restore, I'm just running "zmrestore -a", which I thought would delete the mailbox and restore everything in the backup (based on the documentation), including the messages I deleted. Or, could it be that it was restored, then the redo logs re-deleted everything? How could I check that?

  4. #4
    Join Date
    Aug 2012
    Rep Power


    That was the problem, just my misunderstanding. Restoring to a point in time worked, then re-restoring fully erased the messages again.


Similar Threads

  1. zmrestore from ZCS 5.0.13 to ZCS 6.0.8
    By philwillchen in forum Administrators
    Replies: 1
    Last Post: 10-06-2010, 08:06 PM
  2. Zmrestore not working
    By Tagishltd in forum Administrators
    Replies: 5
    Last Post: 08-24-2010, 08:16 AM
  3. ZMrestore not working
    By fdezmichael in forum Administrators
    Replies: 4
    Last Post: 09-16-2009, 01:25 PM
  4. zmrestore point-in-time recovery not working
    By Rich Graves in forum Administrators
    Replies: 9
    Last Post: 12-12-2007, 07:47 PM
  5. zmrestore -restoreToTime not working
    By jeffw in forum Administrators
    Replies: 2
    Last Post: 12-11-2007, 08:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts