Hi all,
I'm new to the forum, have read the knowledgebase and searched the forum for help with setting up a relay for may mail server. The issue is that I get errors related to authentication, whichever relay I use. I've followed the Wiki on setting up relays, especially the authentication section but it appears that when Zimbra is connecting to the smarthost it's presenting something else or that the smart hosts don't like the way Zimbra is presenting the credentials.

I've tried with socketlabs and smtpcorp and both return authentication errors see below:

May 14 10:07:03 mail postfix/smtp[5571]: 0DEDCC0E33: to=<myfriend@totallychanged.org>, relay=smtpcorp.com[]:25, delay=2.6, delays=0.04/0.08/1.1/1.4, dsn=5.0.0, status=bounced (host smtpcorp.com[] said: 550 relay refused oyuuni@nonrealdomain.org/xxx.96.yyy.101 unauthenticated (in reply to RCPT TO command))
May 14 10:07:03 mail postfix/cleanup[5555]: E2411C0E36: message-id=<20130514080703.E2411C0E36@mail.nonrealdomain.o rg>

May 13 17:23:49 mail postfix/smtp[26489]: 2E533C0E12: enabling PIX workarounds: disable_esmtp delay_dotcrlf for smtp.socketlabs.com[]:25
May 13 17:23:49 mail postfix/smtp[26489]: 2E533C0E12: to=<myfriend@gmail.com>, relay=smtp.socketlabs.com[]:25, delay=1.7, delays=0.02/0.06/1.1/0.6, dsn=5.7.0, status=bounced (host smtp.socketlabs.com[] said: 501-5.7.0 Authentication required. Please authenticate with CRAM MD5 or AUTH Login. 501 5.7.0 see http://support.socketlabs.com/kb/81 for more information. (in reply to RCPT TO command))

In the case of socketlabs, I believe the credentials aren't being presented properly. I have done the following and verified the username and password but the response seems to indicate that these credentials aren't being presented to the socketlabs server.

zmlocalconfig -e postfix_smtp_sasl_auth_enable=yes
echo smtp.socketlabs.com <myusername>:<mypassword> > /opt/zimbra/conf/relay_password
postmap hash:/opt/zimbra/conf/relay_password
postmap -q smtpcorp.com /opt/zimbra/conf/relay_password -- returns correct username/password pair
zmlocalconfig -e postfix_smtp_sasl_password_maps=hash:/opt/zimbra/conf/relay_password
zmlocalconfig -e postfix_smtp_cname_overrides_servername=no
postfix reload

To ensure that the smarthost is actually set up I also did

zmprov ms mail.nonrealdomain.org zimbraMtaRelayHost smtp.socketlabs.com

After all this I still get those authentication errors.

Any pointers?

TIA Osay