Results 1 to 3 of 3

Thread: LDAP error: - unable to get connection to server dummy_host:1

Hybrid View

  1. #1
    Join Date
    Jul 2008
    Posts
    27
    Rep Power
    7

    Default SOLVED: LDAP error: - unable to get connection to server dummy_host:1

    Hey

    After desaster recovery I can not get LDAP up and running.

    Everything I could think of was being checked (I've replaced my hostname with xyz.ab)

    zmlocalconfig | grep ldap | grep url
    ldap_bind_url =
    ldap_master_url = ldap://xyz.ab:389
    ldap_url = ldap://xyz.ab:389
    telnet xyz.ab 389
    Trying 127.0.1.1...
    Connected to /xyz.ab.
    Escape character is '^]'.
    Any ideas where the "dummy_host:1" comes from?? What else can I check?
    Last edited by juergenmw; 05-27-2013 at 11:30 AM.

  2. #2
    Join Date
    Jul 2008
    Posts
    27
    Rep Power
    7

    Default

    This is solved.

    The complete error message was

    LdapException: com.zimbra.cs.ldap.LdapException: LDAP error: - unable to get connection: An error occurred while attempting to connect to server dummy_host:1: java.io.IOException: An error occurred while attempting to establish a connection to server dummy_host:1: org.newsclub.net.unix.AFUNIXSocketException: No such file or directory (socket: /opt/zimbra/openldap-2.4.33.4z/var/run/ldapi)
    and I also had a

    ldif_read_file: checksum error on "/opt/zimbra/data/ldap/config/cn=config/olcDatabase={0}config.ldif"

    I deleted the CRC comment inside the file and after a restart both errors were gone. Maybe someone needs that info some day ...

  3. #3
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    The CRC warning is harmless. For whatever reason, openldap was not able to create the ldapi socket on your system when it was started the first time.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Similar Threads

  1. Unable to open connection to server
    By poweredmail in forum VMware Zimbra for Android
    Replies: 5
    Last Post: 02-24-2012, 07:24 AM
  2. [SOLVED] Unable to establish a secure connection to the server
    By lytledd in forum Zimbra Connector for Outlook
    Replies: 11
    Last Post: 11-11-2011, 09:40 AM
  3. Connection error with Zimbra server.
    By Wilson_Lee in forum Users
    Replies: 9
    Last Post: 12-22-2009, 06:56 PM
  4. Replies: 8
    Last Post: 05-27-2009, 01:32 PM
  5. Replies: 8
    Last Post: 07-30-2008, 02:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •