Results 1 to 3 of 3

Thread: LDAP and Cache issue - Zimbra will not start

  1. #1
    Join Date
    Oct 2012
    Posts
    24
    Rep Power
    3

    Question LDAP and Cache issue - Zimbra will not start

    I have tried all the tricks found on the forum, but still can't figure it out.

    Code:
    # hostname
    www.example.net
    Code:
    # cat /etc/hosts
    127.0.0.1       localhost.localdomain localhost
    192.168.1.1   www.example.com www
    192.168.1.1   www.example.net www
    192.168.1.1   smtp.example.net smtp
    Code:
    ]# /opt/zimbra/bin/zmcertmgr viewdeployedcrt
    ... ... 
    ::service ldap::
    notBefore=Jun  2 09:07:39 2013 GMT
    notAfter=Jun  2 09:07:39 2014 GMT
    Code:
    dig example.net any
    
    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> example.net any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45243
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;example.net.                  IN      ANY
    
    ;; ANSWER SECTION:
    example.net.           478     IN      A       192.168.1.1
    example.net.           478     IN      MX      0 smtp.example.net.
    example.net.           478     IN      NS      ns29.ns.com.
    example.net.           478     IN      NS      ns30.ns.com.
    example.net.           478     IN      SOA     ns29.ns.com. dns.jomax.net. 2013060202 28800 7200 604800 3600
    
    ;; Query time: 20 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Sun Jun  2 09:16:57 2013
    ;; MSG SIZE  rcvd: 168
    when I do a
    Code:
    zmcontrol start
    I get:

    Code:
    [root@www zimbra]# su - zimbra -c 'zmcontrol start'
    Host smtp.example.net
            Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.
    please advise.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Alupis View Post
    I have tried all the tricks found on the forum,
    I don't think you have and they're not 'tricks' it's called configuration requirements.

    Quote Originally Posted by Alupis View Post
    ... but still can't figure it out.
    Read the Split DNS article of the many threads on this topic, your dig output shows no A record for your mail server (your hosts file is also incorrect).
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2012
    Posts
    24
    Rep Power
    3

    Default

    I"m sorry but I still have not figured this out. I think I confused things in my original post... I'm on a single public ip address on a VPS... I changed the real IP address with the "fake" internal addresses.

    I have my DNS set to point my MX record to a CNAME which points to @. So basically The MX record's A record is the "192.168.1.1" but a static public address. Does this change anything?


    EDIT: Oh... RFC 1123 just slapped me in the face.

Similar Threads

  1. Replies: 3
    Last Post: 06-11-2012, 08:20 AM
  2. Replies: 14
    Last Post: 03-16-2011, 08:19 AM
  3. Zimbra LDAP cache / replication?
    By batfastad in forum Administrators
    Replies: 9
    Last Post: 11-26-2010, 07:24 AM
  4. [SOLVED] ldap - cache is out of date or doesn't exist
    By aidanewen in forum Administrators
    Replies: 11
    Last Post: 08-31-2010, 12:10 AM
  5. cache attributes in zimbra LDAP
    By UMDjwain in forum Administrators
    Replies: 3
    Last Post: 06-10-2009, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •