Results 1 to 2 of 2

Thread: ERROR upgrade :7.2.3 to 8.0.3 Duplicate column name 'deleted_by_user'

Hybrid View

  1. #1
    Join Date
    Feb 2010
    Location
    South Africa
    Posts
    107
    Rep Power
    5

    Default ERROR upgrade :7.2.3 to 8.0.3 Duplicate column name 'deleted_by_user'

    I've upgraded a server from 7.2.3 to 8.0.3 and I get this error below. (CentOS6)
    There was a corrupt mboxgroup table that I had to create an empty SQL script for as the exported sql was also corrupt/incomplete.

    ...
    Do you want to verify message store database integrity? [Y] Y
    Verifying integrity of message store databases. This may take a while.
    mysqld is alive
    No errors found
    ...
    Upgrading from 7.2.3_GA_2872 to 8.0.3_GA_5664
    Stopping zimbra services...done.
    Starting mysql...done.
    This appears to be 7.2.3_GA
    Checking ldap status...not running.
    Running zmldapapplyldif...done.
    Checking ldap status...not running.
    Starting ldap...done.
    Checking ldap status...already running.
    Running mysql_upgrade...done.
    Schema upgrade required from version 65 to 92.
    Running /opt/zimbra/libexec/scripts/migrate20120611_7to8_bundle.pl
    Tue Jun 4 00:35:06 2013: Verified schema version 65.
    Tue Jun 4 00:35:07 2013: Adding device information columns to ZIMBRA.MOBILE_DEV ICES table...
    ERROR 1060 (42S21) at line 1: Duplicate column name 'deleted_by_user'
    Tue Jun 4 00:35:08 2013: Error while running '/opt/zimbra/bin/mysql --user=zimb ra --password=TxnET21dIHFiJmjyhYROmRWZv.kjnshu --database=zimbra --batch --skip- column-names'.
    Script failed with code 256: - exiting
    UPGRADE FAILED - exiting.
    Last edited by ekkas; 06-03-2013 at 05:05 PM.

  2. #2
    Join Date
    Feb 2010
    Location
    South Africa
    Posts
    107
    Rep Power
    5

    Default

    Seems due to corrupt mboxgroup, upgrade was half finished. Luckily I made SQL & LDAP exports/backup before, so I could restore SQL from text exports and then upgrade finished succesfully.
    Never underestimate the power of an SQL export.

    Strange thing is, roughly my steps were:
    1)SQL exports+ LDAP backup
    2) Upgrade old CentOS5-64 server from 7.1.3 to 7.2.3 - NO ERRORS
    3) Install software only on new CentOS6-64
    4) Link /opt disk to new server
    5) "Upgrade to 7.2.3" - NO ERRORS - ALL WORKING 100%
    6) Upgrade to 8.0.3 - corrupt mboxgroup detected. Check original backup, also corrupt!

    How did it pass by 2 upgrades and server transfer with no problems, then 7.2.3<->8.0.3 hits the error.

    Anyways, just glad it's fixed.

Similar Threads

  1. Replies: 10
    Last Post: 02-27-2013, 08:47 PM
  2. Replies: 0
    Last Post: 02-21-2013, 10:18 PM
  3. TO and From Column
    By carloimperia in forum General Questions
    Replies: 0
    Last Post: 06-30-2012, 12:59 AM
  4. POP 3 account error. Duplicate email
    By tandthamera in forum Error Reports
    Replies: 1
    Last Post: 10-17-2010, 11:54 PM
  5. Error during upgrade: Duplicate key name 'i_name'
    By hodel in forum Installation
    Replies: 6
    Last Post: 04-27-2006, 07:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •