Results 1 to 7 of 7

Thread: In Zimbra 8.x Web Client black icons in toolbar

Hybrid View

  1. #1
    Join Date
    May 2010
    Posts
    46
    Rep Power
    5

    Question In Zimbra 8.x Web Client back icons in toolbar

    Hello,

    At previous version 7.x UI of Web Client was nicer in my opinion. So it is some possibility back again in Zimbra 8.x Web Client icons?
    zimbra-ui-7.PNG
    Last edited by tdslot; 09-12-2013 at 12:54 PM.

  2. #2
    Join Date
    Nov 2011
    Posts
    19
    Rep Power
    4

    Default

    I second this. How do we get this back?

  3. #3
    Join Date
    Mar 2008
    Posts
    31
    Rep Power
    7

    Default

    Filed

    "ZWC 8+ to offer older ZCS7- style ZWC interface"
    Bug 83965 – ZWC 8+ to offer older ZCS7- style ZWC interface

  4. #4
    Join Date
    May 2010
    Posts
    46
    Rep Power
    5

    Default

    Ajcody,

    Thanks for reaction. We will wait for new theme

  5. #5
    Join Date
    Nov 2011
    Posts
    19
    Rep Power
    4

    Default

    Hello Zimbra Users and Administrators. I noticed there have been 200+ views of this thread. Please see the filed bug and vote for this so that it can perhaps get on the radar of their programming team.

    https://bugzilla.zimbra.com/show_bug.cgi?id=83965


    Thanks.

  6. #6
    Join Date
    May 2010
    Posts
    46
    Rep Power
    5

    Default

    Hello,

    It's nice that other supporting my idea for adding Icons to theme. ZWC8 theme is white nice it just need add Icons to action buttons. But it can be Ribbon toolbar also in new theme like Outlook 2010/2014. Then ZWC8 will look really fresh

  7. #7
    Join Date
    Feb 2010
    Location
    WNY
    Posts
    12
    Rep Power
    5

    Default

    Quote Originally Posted by Calmetrics View Post
    Hello Zimbra Users and Administrators. I noticed there have been 200+ views of this thread. Please see the filed bug and vote for this so that it can perhaps get on the radar of their programming team.

    https://bugzilla.zimbra.com/show_bug.cgi?id=83965


    Thanks.
    Things tend to take time for such things.

    I recommend overriding a few simple things in css to show icons in toolbar.

    First - its as simple as targeting the right ids - Ill foucs on DELETE icon because it appears on many views.
    The toolbar will have different ids for the same icons depending on what view you are in.
    for example look at a few ids for the delete icon...

    <td id="zb__TV-main__DELETE_left_icon" class="ZLeftIcon ZWidgetIcon"></td>
    <td id="zb__CNS-main__DELETE_left_icon" class="ZLeftIcon ZWidgetIcon"></td>
    <td id="zb__CLD__DELETE_left_icon" class="ZLeftIcon ZWidgetIcon"></td>
    <td id="zb__TKL-main__DELETE_left_icon" class="ZLeftIcon ZWidgetIcon"></td>

    Luckily there is consistancy here. There is only a name change in the middle of the name. The beginning and end are the same.
    id="zb__ [unique Name ] __DELETE_left_icon"

    This can be identified in css as so...
    .ZToolbar td[id^="zb__"][id$="__DELETE_left_icon"] {
    background: url("/skins/SKINNAME/IMAGEPATH/IconDelete.png") no-repeat scroll X Y;
    }

    the above is a decent example for replacing the icon, but what about icons that never show?
    you can do the exact same thing, but you will want to add /change a few things for all browsers to support it.

    Lets take the REPLY icon...
    You can apply the code above with replacing DELETE for REPLY and add a width attribute, and you would see this work fine in firefox.
    Unfortuantely does not work for me in chrome (37.x), safari (6.x), and IE (Quirks mode [sucks] 5.5).
    I am presently on ZCS 8.0.7 right now, this may be different on other versions.

    My fix for this was quite simple though. Since the width was not taking effect because there was no content in the TD tag, replace width with left padding!
    .ZToolbar td[id^="zb__"][id$="__REPLY_left_icon"] {
    background: url("/skins/SKINNAME/IMAGEPATH/IconReply.png") no-repeat scroll X Y;
    padding-left: 20px;
    }

    with sample code above make changes to help suit your work and the example calls out individual png files. Sprites work too! just o what works for you.

    This at least is working well for me, and thought I'd share.

    PS - you might have to call out ids specifically to support IE quirks 5.5 ( boo! )

Similar Threads

  1. Change icons in zimbra.
    By stalker in forum Developers
    Replies: 0
    Last Post: 03-24-2011, 03:59 AM
  2. A Zimbra Toolbar?
    By jholder in forum Users
    Replies: 29
    Last Post: 03-03-2011, 01:51 AM
  3. Zimbra Address Book Toolbar Button
    By jonnybravo in forum Zimlets
    Replies: 0
    Last Post: 05-28-2008, 10:31 AM
  4. Wrong icons in GA Zimbra web client
    By iain in forum Users
    Replies: 2
    Last Post: 02-13-2006, 03:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •