Hi experts,

we deploying new installation for ZCS

this is my /etc/hosts File :

127.0.0.1 localhost.localdomain localhost
#::1 localhost6.localdomain6 localhost6
192.168.1.2 mail.sub.maindomain.com mail
-------------------------------------------------------------------------
Dig Result

[root@mail ~]# dig mx sub.maindomain.com

; <<>> DiG 9.3.6-P1-RedHat-9.3.6-20.P1.el5_8.6 <<>> mx sub.maindomain.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46642
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;subdomain.maindomain.com IN MX

;; ANSWER SECTION:
sub.maindomain.com. 604800 IN MX 0 mail.sub.maindomain.com.

;; AUTHORITY SECTION:
sub.maindomain.com. 604800 IN NS localhost.

;; ADDITIONAL SECTION:
mail.sub.maindomain.com. 604800 IN A 192.168.1.2

;; Query time: 6 msec
;; SERVER: 192.168.1.3#53(192.168.1.3)
;; WHEN: Wed Jun 19 13:06:43 2013
;; MSG SIZE rcvd: 96
--------------------------------------------------------------------
/etc/resolve.conf

[root@mail ~]# cat /etc/resolv.conf
nameserver 192.168.1.3


as we behind Firewall between 192.168.1.3 is internal DNS

I send and receive mails good to outside domain but when i send it to maindomain.com its loop back with this error message

This is the mail system at host mail.sub.maindomain.com

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<account@maindomain.com>: mail for maindomain.loops back to myself

any help?????