I have a working version of zimbra 5.0.18. Email flows in and out for my public domain: westcoasteden.com. I used the default domain: example.com during the initial install. My /etc/hosts file is as follows:
127.0.0.1 localhost.localdomain localhost
127.0.1.1 zimbra
127.0.1.1 zimbra.example.com zimbra
127.0.0.1 mail.example.com mail

My /etc/resolv.conf is:
nameserver 127.0.0.1
search example.com gv.shawcable.net

I am using dnsmaq, not bind. I followed the instructions on the Split DNS document to get email flowing for the public domain: westcoasteden.com. I can send and receive email to/from accounts on this domain.

After getting email working I wanted to upgrade to a newer version. I downloaded and extracted the files for the 7.2.4 version (my box is 32-bit). But, when I try to upgrade by running ./install.sh, I receive the following:

ERROR: Installation can not proceeed. Please fix your /etc/hosts file
to contain:

<ip> <FQHN> <HN>

Where <IP> is the ip address of the host,
<FQHN> is the FULLY QUALIFIED host name, and
<HN> is the (optional) hostname-only portion

to try to resolve the issue, I created an A record for zimbra.westcoasteden.com and used (96.50.10.110 zimbra.westcoasteden.com zimbra) in my /etc/hosts, but that also did not work. I also tried changing that to: 127.0.0.1 zimbra.example.com zimbra and then to 127.0.1.1, but neither worked.


After I make a change, I am restarting both /etc/init.d/networking and /etc/init.d/dnsmasq. My version of Linux is Ubuntu 8.04.