Results 1 to 6 of 6

Thread: Zimbra Maximum Message Size for external mail

Hybrid View

  1. #1
    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    2

    Default Zimbra Maximum Message Size for external mail

    Hello,

    I had a request from a customer to increase the message size limit for his Zimbra installation. I have followed the instructions in the Wiki (Configuring maxmessagesize - Zimbra :: Wiki) but when trying to send a message larger than 10 MB from gmail or yahoo it bounced back.

    I blamed it on an out of date installation of Zimbra, so I proceeded to upgrade to version ZCS - 8.0.4, but after the upgrade the problem persisted. On further investigation I've noticed that for local mail (i.e user1@domain to user2@domain) the limit I've set worked, but for external mail it didnt. In /var/log/messages I've noticed the following error message:
    Code:
     Jul 10 19:04:04 mail postfix/smtpd[4198]: lost connection after DATA (9997998 bytes) from mail-ie0-f171.google.com[209.85.223.171]
    When telneting from a host in mynetworks the size is reported according to the limit set in postfix main.cf:
    Code:
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mail.-----.--- ESMTP Postfix
    ehlo -------.---
    250-mail.-------.---
    250-PIPELINING
    250-SIZE 44040192
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    But when trying to telnet from an external address the size is listed as following:
    Code:
    Trying 89.121.205.74...
    Connected to mail.-------.---.
    Escape character is '^]'.
    220 mail.-------.--- ESMTP Service ready
    ehlo -------.---
    250-Requested mail action okay, completed
    250-SIZE 10000000
    250-ETRN
    250-8BITMIME
    250-STARTTLS
    250 OK
    I thought the difference was from cbpolicyd, so I've disabled it and restarted Zimbra, but to no avail.

    Does anyone know how postfix is configured to report different sizes and how can I configure it for the customer to be able to receive mails according to message_size_limit?

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    You're going to have to give details of the changes you've made and to which settings, run zmprov to get all the details and post the output here.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    2

    Default

    I've run the commands according to the wiki:

    Code:
    zmprov ms `zmhostname` zimbraFileUploadMaxSize 44040192
    zmprov ms `zmhostname` zimbraMailContentMaxSize 44040192
    zmprov mcf zimbraMtaMaxMessageSize 44040192
    postfix reload
    After that I've restarted zimbra:
    Code:
    zmcontrol restart
    and then disabled cbpolicyd:
    Code:
    zmprov ms 'zmhostname' -zimbraServiceEnabled cbpolicyd
    Here's the output of zmcontrol status:
    Code:
    [zimbra@mail ~]$ zmcontrol status
    Host mail.-------.---
    	antispam                Running
    	antivirus               Running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Running
    	memcached               Running
    	mta                     Running
    	opendkim                Running
    	snmp                    Running
    	spell                   Running
    	stats                   Running
    	zmconfigd               Running

  4. #4
    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    2

    Default

    Unfortunately the output of zmprov gac -v is over 20000 chars long so I cannot post it. If you can direct me to the correct CLI command I would be grateful.

    Initially I've set the max message size according to the wiki:

    Code:
    zmprov ms `zmhostname` zimbraFileUploadMaxSize 44040192
    zmprov ms `zmhostname` zimbraMailContentMaxSize 44040192
    zmprov mcf zimbraMtaMaxMessageSize 44040192
    postfix reload
    Then I've disabled cbpolicyd:
    Code:
     zmprov ms 'zmhostname' -zimbraServiceEnabled cbpolicyd
    and afterwards restarted Zimbra.

    Also, here is the output of zmcontrol status:

    [zimbra@mail ~]$ zmcontrol status
    Code:
    Host mail.--------.---
    	antispam                Running
    	antivirus               Running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Running
    	memcached               Running
    	mta                     Running
    	opendkim                Running
    	snmp                    Running
    	spell                   Running
    	stats                   Running
    	zmconfigd               Running

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    To list those fields you've modified use the following:

    Code:
    zmprov gacf  zimbraMtaMaxMessageSize zimbraFileUploadMaxSize zimbraMailContentMaxSize
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    Join Date
    Jul 2013
    Posts
    5
    Rep Power
    2

    Default

    Here's the output:

    Code:
    [zimbra@mail ~]$ zmprov gacf  zimbraMtaMaxMessageSize zimbraFileUploadMaxSize zimbraMailContentMaxSize
    zimbraFileUploadMaxSize: 49999872
    zimbraMailContentMaxSize: 39845888
    zimbraMtaMaxMessageSize: 44040192

Similar Threads

  1. Confused On Maximum Message Size
    By soxfan in forum Administrators
    Replies: 6
    Last Post: 06-25-2013, 08:20 PM
  2. Set different maximum message size depending on recipient
    By molybtek in forum Administrators
    Replies: 0
    Last Post: 06-10-2010, 05:11 PM
  3. [SOLVED] Maximum message size
    By KenVM in forum Administrators
    Replies: 21
    Last Post: 01-21-2008, 12:28 AM
  4. Replies: 0
    Last Post: 08-06-2007, 05:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •