Results 1 to 4 of 4

Thread: ldap issue

Hybrid View

  1. #1
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default ldap issue

    Hi All

    We put a new server in to a customer about 2 months ago. The server has run with out a hitch until the last couple of days (Release 8.0.3.GA.5664.UBUNTU10.64 UBUNTU10_64 FOSS edition.)

    Every day the web front end seems to stop responding, inside the zimbra logs we see

    Jul 30 09:04:22 server16 slapd[1034]: slap_queue_csn: queing 0x7f10d1cf51a0 20130730080422.447191Z#000000#000#000000
    Jul 30 09:04:22 server16 slapd[1034]: slap_graduate_commit_csn: removing 0x5f98570 20130730080422.447191Z#000000#000#000000
    Jul 30 09:04:25 server16 slapd[1034]: slap_queue_csn: queing 0x7f10d04f21a0 20130730080425.732083Z#000000#000#000000
    Jul 30 09:04:25 server16 slapd[1034]: slap_graduate_commit_csn: removing 0x33aecc0 20130730080425.732083Z#000000#000#000000
    Jul 30 09:04:25 server16 slapd[1034]: slap_queue_csn: queing 0x7f10d04f21a0 20130730080425.787335Z#000000#000#000000
    Jul 30 09:04:25 server16 slapd[1034]: slap_graduate_commit_csn: removing 0x5f98ab0 20130730080425.787335Z#000000#000#000000

    If we try to restart the server we see

    Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.

    To get it all up and running again we need to do a full server reboot. No setting have been changed, no new mailbox or domain etc

    Anyone got any ideas here please

    Thanks

    Glenn

  2. #2
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default

    Still crashing and managed to catch these logs

    Jul 31 10:36:32 server16 postfix/proxymap[22073]: error: dict_ldap_connect: Unable to set STARTTLS: -1: Can't contact LDAP server
    Jul 31 10:36:32 server16 postfix/trivial-rewrite[22072]: warning: proxy:ldap:/opt/zimbra/conf/ldap-vad.cf: table lookup problem
    Jul 31 10:36:32 server16 postfix/trivial-rewrite[22072]: warning: virtual_alias_domains lookup failure
    Jul 31 10:36:33 server16 postfix/proxymap[26721]: error: dict_ldap_connect: Unable to set STARTTLS: -1: Can't contact LDAP server
    Jul 31 10:36:33 server16 postfix/trivial-rewrite[26722]: warning: proxy:ldap:/opt/zimbra/conf/ldap-transport.cf lookup error for "*"
    Jul 31 10:36:36 server16 zmconfigd[12999]: Thread gc still alive, aborting
    Jul 31 10:36:36 server16 zmconfigd[12999]: LOCK myState.lConfig released
    Jul 31 10:36:36 server16 zmconfigd[12999]: File "/opt/zimbra/libexec/zmconfigd", line 193, in <module> myState.getAllConfigs(myConfig)
    Jul 31 10:36:36 server16 zmconfigd[12999]: File "/opt/zimbra/zimbramon/pylibs/state.py", line 311, in getAllConfigs raise e
    Jul 31 10:36:36 server16 zmconfigd[12999]: Sleeping...Key lookup failed (Thread gc still alive, aborting)
    Jul 31 10:36:43 server16 postfix/proxymap[26724]: error: dict_ldap_connect: Unable to set STARTTLS: -1: Can't contact LDAP server
    Jul 31 10:36:43 server16 postfix/trivial-rewrite[19646]: warning: proxy:ldap:/opt/zimbra/conf/ldap-vad.cf: table lookup problem
    Jul 31 10:36:43 server16 postfix/trivial-rewrite[19646]: warning: virtual_alias_domains lookup failure

    This is a dedicated server running ubuntu 10.4 with 16gb of ram
    Last edited by glennbtn; 08-01-2013 at 02:57 AM.

  3. #3
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    You really should run 8.0.4. There's corruption issues with the ldap server in 8.0.3. That's why I'm constantly telling people to upgrade to 8.0.4.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #4
    Join Date
    Dec 2009
    Location
    Worthing. UK
    Posts
    97
    Rep Power
    5

    Default

    Many thanks.

    I have not seen these so will arrange to get this done asap

Similar Threads

  1. Adding LDAP indices issue
    By Playmaker2 in forum Administrators
    Replies: 0
    Last Post: 08-19-2011, 11:27 AM
  2. LDAP Filter issue and GAL
    By G-Money in forum Administrators
    Replies: 2
    Last Post: 06-24-2010, 12:13 PM
  3. Thunderbird LDAP/GAL Issue
    By razi.ahmad in forum Administrators
    Replies: 0
    Last Post: 07-02-2008, 08:47 AM
  4. Issue with LDAP replication
    By peter@mxtoolbox.com in forum Administrators
    Replies: 0
    Last Post: 06-08-2007, 02:31 PM
  5. LDAP Authentication issue
    By premoddev in forum Administrators
    Replies: 7
    Last Post: 12-22-2006, 07:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •