Results 1 to 10 of 13

Thread: zmspamextract issue

Hybrid View

  1. #1
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default zmspamextract issue

    Hello,

    am trying to achieve per user spamassassin bayes training and leveraging the existing Zimbra scripts. The problem I am facing is when I do
    Code:
    /opt/zimbra/libexec/zmspamextract -r -m myuser@mydomain -o /tmp/hambox -q in:Inbox -v
    it pulls out 26 messages and then dies with
    Code:
    [] INFO: Wrote: /tmp/hambox/14035b07a95-26
    [] WARN: exception occurred fetching message
    java.io.IOException: HTTP GET failed: /service/user/myuser@mydomain.com/?id=44731: 503: Service Unavailable
    	at com.zimbra.cs.util.SpamExtract.extractMessage0(SpamExtract.java:314)
    	at com.zimbra.cs.util.SpamExtract.extractMessage(SpamExtract.java:296)
    	at com.zimbra.cs.util.SpamExtract.extract(SpamExtract.java:245)
    	at com.zimbra.cs.util.SpamExtract.main(SpamExtract.java:194)
    any thoughts on would could be causing it ?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Ah! I wonder if this is kicking in yet nothing in the sync.log DoSFilter - Zimbra :: Wiki

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Even setting the server IP via
    Code:
    zmprov mcf zimbraHttpThrottleSafeIPs
    does not fix it

  4. #4
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    Hi,

    This is https://bugzilla.zimbra.com/show_bug.cgi?id=83271

    Note that you must restart each mailbox server after adding your MTAs to the zimbraHttpThrottleSafeIPs values. Then you can run zmtrainsa.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Hey quanah,

    I was performing the actions on the mailstore and added its IP to the the Throttle variable. zmspamextract was calling against that node as-well when I viewed it in the debug.

    Thank you.

  6. #6
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,285
    Rep Power
    10

    Default

    mailstores supposedly whitelist themselves, so it shouldn't hit this error when run on a mailstore..
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Similar Threads

  1. Issue
    By jaswanth.y in forum Installation Help
    Replies: 0
    Last Post: 06-19-2011, 10:58 PM
  2. DNS issue
    By Mugster in forum Administrators
    Replies: 2
    Last Post: 04-08-2011, 04:22 PM
  3. Local mail issue or setup issue?
    By FlyingFish in forum Administrators
    Replies: 0
    Last Post: 09-22-2009, 09:04 AM
  4. dns issue with suse 10.2 and issue with bind
    By zjustin in forum Installation
    Replies: 11
    Last Post: 05-06-2007, 11:18 AM
  5. Intermittent issue (issue# 5852) ?
    By nick20 in forum Installation
    Replies: 1
    Last Post: 02-08-2006, 01:47 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •