Results 1 to 2 of 2

Thread: cacert.asc with LDAPS - certificate issue with TLS/SSL

  1. #1
    Join Date
    Aug 2013
    Rep Power

    Default cacert.asc with LDAPS - certificate issue with TLS/SSL

    I am attempting to connect my zimbra instance to my newer LDAP server that uses 389 Directory Server. I have TLS/SSL enabled on the LDAP server and most of the servers are happy to work with it. I usually set the ldap up in the /etc/ldap.conf and everything is happy. When adding the server to the Authentication tab in the Admin Console, I click SSL and ldaps:// comes up as it should. I put the bind DN and password in, everything seems fine. The Test cinfig button shows the following error:

    "SSL connect problem, most likely untrusted certificate"

    How do I get this certificate to be trusted?

    Most of my clients use a cacert.asc file to verify the cert. Any ideas why I cannot get zimbra to look to this cacert.asc file to verify things? I have placed it in the /etc/openldap/cacerts and /opt/zimbra/ssl/zimbra/ca/

    Do I need to edit the /opt/zimbra/ssl/zimbra/ca/zmssl.conf file? In what way? Specifying a cacert file is possible here? If not how would I convert it to the pem crt csr key format?

    This is all so my zimbra server can do LDAP(S) lookups to another server on my network. No one will look to the cacert.asc except my zimbra server.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Vannes, France
    Rep Power


    Quote Originally Posted by shockwavecs View Post
    How do I get this certificate to be trusted?
    Take a look at some of these threads.


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Need help on issue with ldaps in zimbra
    By tshrinivasan in forum Administrators
    Replies: 0
    Last Post: 08-16-2012, 11:53 AM
  2. Certificate Issue
    By glennbtn in forum Administrators
    Replies: 3
    Last Post: 07-20-2012, 07:55 PM
  3. Zimbra SSL Certificate Issue
    By kumabhi in forum Administrators
    Replies: 6
    Last Post: 11-22-2010, 10:51 AM
  4. [SOLVED] CAcert certificate
    By pc-dok in forum Administrators
    Replies: 8
    Last Post: 07-26-2010, 11:10 AM
  5. [SOLVED] Problem when install CAcert certificate
    By bibo in forum Administrators
    Replies: 4
    Last Post: 11-17-2008, 04:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts