Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: upgraded to 4.5 (OS edition), now no dspam?

  1. #11
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    It looks like the .spamassassin directory (and therefor dbs) didn't get migrated during the upgrade. 4.0.3 to 4.5.0 upgraded amavis from 2.4.1 to 2.4.3 You should be able to

    Code:
    mv /opt/zimbra/amavisd-new-2.4.3/.spamassassin/.spamassassin.tmp /opt/zimbra/amavisd-new-2.4.3/.spamassassin.tmp
    rm -rf /opt/zimbra/amavisd-new-2.4.3/.spamassassin
    mv /opt/zimbra/amavisd-new-2.4.3/.spamassassin /opt/zimbra/amavisd-new-2.4.3/.spamassassin
    Last edited by brian; 01-23-2007 at 03:37 PM.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  2. #12
    Join Date
    Oct 2006
    Posts
    24
    Rep Power
    9

    Default

    Quote Originally Posted by brian View Post
    It looks like the .spamassassin directory (and therefor dbs) didn't get migrated during the upgrade. 4.0.3 to 4.5.0 upgraded amavis from 2.4.1 to 2.4.3 You should be able to

    Code:
    rm -rf /opt/zimbra/amavisd-2.4.3/.spamassassin
    mv /opt/zimbra/amavisd-2.4.1/.spamassassin /opt/zimbra/amavisd-2.4.3/.spamassassin
    My dirs are called amavisd-new-2.4.[13], but I don't have a .spamassassin directory in the 2.4.1 directory.

    My 4.0.3 backup has:
    Code:
    -rw-------  1 zimbra zimbra 10510336 Jan 17 19:15 auto-whitelist
    -rw-------  1 zimbra zimbra    78072 Jan 17 19:15 bayes_journal
    -rw-r--r--  1 zimbra zimbra  2609152 Jan 17 19:07 bayes_seen
    -rw-------  1 zimbra zimbra  5267456 Jan 17 19:07 bayes_toks
    but the .spamassassin in the post-upgrade 2.4.3 dir has:
    Code:
    -rw-------  1 zimbra zimbra  339968 Jan 20 11:00 auto-whitelist
    -rw-------  1 zimbra zimbra  103008 Jan 20 11:00 bayes_journal
    -rw-r--r--  1 zimbra zimbra   81920 Jan 20 10:44 bayes_seen
    -rw-r--r--  1 zimbra zimbra 1302528 Jan 20 10:44 bayes_toks
    So that's a little suspicious, from my understanding of how bayes_seen works. I'm going to save off that directory in the live version and replace it with the contents from the backup, and see if that helps at all...

    I wonder if it migrated and then re-initialized the .spamassassin stuff, which would be a little bit sadmaking.

    Edit: oh ho!

    The new amavisd-new-2.4.3 dir's .spamassassin also has a directory called .spamassassin.tmp, which has some familiar files in it!

    Code:
    -rw-------  1 zimbra zimbra 10510336 Jan 17 19:15 auto-whitelist
    -rw-------  1 zimbra zimbra    78072 Jan 17 19:15 bayes_journal
    -rw-r--r--  1 zimbra zimbra  2609152 Jan 17 19:07 bayes_seen
    -rw-------  1 zimbra zimbra  5267456 Jan 17 19:07 bayes_toks
    Is that a sign of a futzed migration? Did I put something in backwards?

    Mike
    Last edited by shaver; 01-20-2007 at 09:25 AM. Reason: Adding more evidence.

  3. #13
    Join Date
    Oct 2006
    Posts
    24
    Rep Power
    9

    Smile

    Quote Originally Posted by shaver View Post
    The new amavisd-new-2.4.3 dir's .spamassassin also has a directory called .spamassassin.tmp, which has some familiar files in it!

    Code:
    -rw-------  1 zimbra zimbra 10510336 Jan 17 19:15 auto-whitelist
    -rw-------  1 zimbra zimbra    78072 Jan 17 19:15 bayes_journal
    -rw-r--r--  1 zimbra zimbra  2609152 Jan 17 19:07 bayes_seen
    -rw-------  1 zimbra zimbra  5267456 Jan 17 19:07 bayes_toks
    I copied these files back over the current ones (with amavisd stopped at the time, natch), and now my beloved BAYES_99 has returned. Thanks a ton for the help, everyone!

    Mike

  4. #14
    Join Date
    May 2006
    Location
    England.
    Posts
    927
    Rep Power
    10

    Default

    Will this be repaired in a fix release (4.5.1?) or should I set about fixing it myself?

  5. #15
    Join Date
    Apr 2006
    Location
    Williamsburg, VA
    Posts
    451
    Rep Power
    9

    Default

    Quote Originally Posted by shaver View Post
    I copied these files back over the current ones (with amavisd stopped at the time, natch), and now my beloved BAYES_99 has returned. Thanks a ton for the help, everyone!

    Mike
    We appear to have experienced the same issue. RHEL 4.03 --> 4.5GA upgrade

  6. #16
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    It would appear that the install is wiping the .spamassassin dir from the other amavisd-new-2.x.x dirs during the migration.

    Please see:
    http://bugzilla.zimbra.com/show_bug.cgi?id=13947

    The guys are really great about getting to the major bugs.

  7. #17
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    This will be fixed in 4.5.1. As shaver indicated the correct files are in /opt/zimbra/amavisd-new-2.4.3/.spamassassin/.spamassassin.tmp
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #18
    Join Date
    Sep 2006
    Posts
    30
    Rep Power
    9

    Default Even more trouble now...

    Quote Originally Posted by brian View Post
    This will be fixed in 4.5.1. As shaver indicated the correct files are in /opt/zimbra/amavisd-new-2.4.3/.spamassassin/.spamassassin.tmp
    I followed the suggestions to move the .spammassassin.tmp folder to .spamassasin and enable DSPAM and now I get this error when starting up amavisd:

    Problem in the antispam SA code: Can't locate Mail/SpamAssassin.pm in @INC (@INC contains: /System/Library/Perl/5.8.6/darwin-thread-multi-2level /System/Library/Perl/5.8.6 /Library/Perl/5.8.6/darwin-thread-multi-2level /Library/Perl/5.8.6 /Library/Perl /Network/Library/Perl/5.8.6/darwin-thread-multi-2level /Network/Library/Perl/5.8.6 /Network/Library/Perl /System/Library/Perl/Extras/5.8.6/darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.6 /Library/Perl/5.8.1 .) at (eval 44) line 16.
    BEGIN failed--compilation aborted at (eval 44) line 16

    Also, when attempting to train the filter, I get:

    ERROR: the Bayes learn function returned an error, please re-run with -D for more information
    fetchmail: MDA returned nonzero status 2
    not flushed
    reading message sourceh@sourcehound.com@zimbra.sourcehound.com:2 of 1000 (1666 header octets) . (12631 body octets) .......^Cfetchmail: terminated with signal 2
    bayes: cannot open bayes databases /opt/zimbra/amavisd/.spamassassin/bayes_* R/W: tie failed: No such file or directory
    Training DSPAM

    So all that's working for me right now are the blacklists...so lots of SPAM

  9. #19
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    10

    Default

    Quote Originally Posted by sourcehound View Post
    sourceh@sourcehound.com@zimbra.sourcehound.com:2 of 1000 (1666 header octets) . (12631 body octets) .......^Cfetchmail: terminated with signal 2
    bayes: cannot open bayes databases /opt/zimbra/amavisd/.spamassassin/bayes_* R/W: tie failed: No such file or directory
    I'll let one of the other guys tackle why it can't find the Spamassassin Perl modules, but the above almost looks like it might be a permissions issue.

    If you do:

    ls -la /opt/zimbra/amavisd/.spamassassin/

    Is everything there owned by the user and group "zimbra"?
    -Eric

  10. #20
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    If it's not the problem that Eric has mentioned, I would suggest rolling back that change and waiting for 4.5.1 which will be out this week.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. OS edition hot standby server
    By fviero in forum Administrators
    Replies: 10
    Last Post: 06-15-2007, 11:34 AM
  2. Configuring and using DSPAM
    By JoshuaPrismon in forum Administrators
    Replies: 55
    Last Post: 03-02-2007, 09:08 AM
  3. Successful Mac OS X upgrade of 4.05 -> 4.5?
    By mbd in forum Installation
    Replies: 3
    Last Post: 02-14-2007, 09:51 PM
  4. Replies: 1
    Last Post: 12-19-2006, 02:58 PM
  5. OS Requirements for Network Edition
    By mrichard in forum Installation
    Replies: 6
    Last Post: 11-22-2006, 02:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •