Results 1 to 3 of 3

Thread: Moving Zimbra Web Client from one port to another.

Hybrid View

  1. #1
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default Moving Zimbra Web Client from one port to another.

    Hi.

    I recently moved our zimbra install from port 8888 to port 80 using zmprov ms hostname zimbraMailPort 80.

    It's working well!

    My problem is that our 'mail' and 'MX' DNS records point to the same IP as our mail web server. So I'm forwarding the traffic to the Web Client from the firewall using a different IP and different hostname 'zimbra.domain.com'.

    It's working well!

    The only thing that isn't working is that suddenly, all IMAP and pop clients (Mail on MAC OSX and Outlook and Outlook Express) have lost the ability to SEND MAIL.

    Everyone is getting bad password messages. I checked and the problem is that all SMTP auth is gone, even though it appears to be on. If I turn off SMTP auth and 'use tls' in my Mail client, they send just fine. Meaning, my SMTP service is running pretty much wide open! : ( uh oh I can telnet in on port 25 and send mail just fine. So somehow, by moving this port I've broken my authentication for smtp even though IMAP and POP and the web client are all working really well.

    So I checked zmprov by... zmprov gs hostname | grep Auth

    and found:

    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: mail.mydomain.com
    zimbraMtaAuthURL: http://mail.mydomain.com/service/soap
    zimbraMtaTlsAuthOnly: TRUE

    Those seem ok to me, but no auth is being enforced at all. Is that URL being used by the client machines outside the firewall.... in which case it'd need to be http://zimbra.mydomain.com/service/soap.

    I've fiddled with those two settings a bit but haven't effected any change in the behaviour of my system. No matter how I set them up it seems the same... web client is fine, imap is fine, pop is fine, but smtp is messed up, because it's running wide open with no auth and no tls.

    Can anyone point me to an article I'm missing or suggest some settings I might want to check or just assure me that zimbraMtaAuthURL is never used by anything outside my firewall?

    Sorry to not have provided more info, I'm just not sure what else to post so hopefully if I've missed something obvious that would be helpful you could let me know.

    Many thanks,
    Heath

  2. #2
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    On the MTA run this and make sure it adds up. If not restart the MTA and that should publish the right URL.

    cat /opt/zimbra/cyrus-sasl/etc/saslauthd.conf
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default Thanks

    Thanks, I had a support ticket and someone from Zimbra went through several settings with me confirming that everything was ok. It was, we changed nothing and it mysteriously started working.

    Some service or part of a service must have got restarted and finally flushed some cache or picked up it's new setting!

    Anyway, everything is working and lovely. Thanks.

Similar Threads

  1. Removing hostname from hosts file fixed prob.
    By lemur in forum Installation
    Replies: 10
    Last Post: 06-13-2007, 07:29 PM
  2. svn version still won't start
    By kinaole in forum Developers
    Replies: 0
    Last Post: 10-04-2006, 07:47 AM
  3. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  4. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 05:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •