Results 1 to 3 of 3

Thread: Installation Success - but no HTTPS for admin?

  1. #1
    Join Date
    Jan 2007
    Posts
    2
    Rep Power
    8

    Default Installation Success - but no HTTPS for admin?

    I've installed ZCS on CentOS successfully, and can send/receive email with users whom I've set up via the command line interface (CLI). What I cannot do is connect to the https server instance to administer the server via the web as the server is not listening on a secure port. I've verified this with nmap.

    Attempted connections to the secure port simply timeout. I've tried overriding the default SSL port and setting it to 8443 - still no go.

    My initial thoughts were the "cannot write 'random state'" error openSSL tossed out while creating a csr/cert during installation were the culprit, but after chasing the root of this error it seems the self-signed cert is created just fine (I've seen posts indicating the error is harmless).

    I then thought tomcat's server.xml didn't have a connector definition for SSL. Sure enough, it does, and looks to be configured properly.

    My last thought is in tomcat's startup, if it can't resolve the host properly with a DNS lookup, that the secure server won't start. But I don't see any indication of this in the tomcat log files.

    Any help or ideas would be appreciated.

  2. #2
    Join Date
    Sep 2005
    Posts
    274
    Rep Power
    10

    Default

    Check your firewall settings.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Jan 2007
    Posts
    2
    Rep Power
    8

    Default Bingo

    Thanks! - that gave me the direction needed. iptables was not allowing https traffic, even though I had enabled it in the firewall configuration during the initial OS setup.

    Adding the lines:
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 443 -j ACCEPT
    -A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 7071 -j ACCEPT

    to the /etc/sysconfig/iptables (and restarting iptables) was the solution.

Similar Threads

  1. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-17-2006, 11:38 PM
  2. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 07:19 AM
  3. Replies: 16
    Last Post: 01-05-2006, 08:55 AM
  4. Installation on FC3 under Xen
    By andreground in forum Installation
    Replies: 9
    Last Post: 11-14-2005, 09:29 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 08:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •