Results 1 to 5 of 5

Thread: ERROR: service.PROXY_ERROR (error while proxying request to target server: HTTP/1.1 4

Hybrid View

  1. #1
    Join Date
    Aug 2013
    Posts
    2
    Rep Power
    2

    Default ERROR: service.PROXY_ERROR (error while proxying request to target server: HTTP/1.1 4

    Good day,

    I beg your pardon but I need a bit support.
    I have updated our 7.1.2. to 7.2.4. This worked without any problems.

    Later I upgraded the 7.2.4 to 8.0.4 and now I am not able to log in via GUI.
    Login through Outlook works.

    At the moment the GUI says if I try to login: "an error networks services has occurred"
    and zmprov is not usable:

    [zimbra@zimbra ~]$ zmprov -v
    ERROR: service.PROXY_ERROR (error while proxying request to target server: HTTP/1.1 404 Not Found)
    com.zimbra.common.service.ServiceException: error while proxying request to target server: HTTP/1.1 404 Not Found
    ExceptionId:main:1377775918433:07bad5fe36d358da
    Code:service.PROXY_ERROR Argurl, STR, "https://localhost:7071/service/admin/soap/AuthRequest")
    at com.zimbra.common.service.ServiceException.PROXY_E RROR(ServiceException.java:327)
    at com.zimbra.common.soap.SoapHttpTransport.invoke(So apHttpTransport.java:242)
    at com.zimbra.common.soap.SoapHttpTransport.invoke(So apHttpTransport.java:167)
    at com.zimbra.common.soap.SoapTransport.invoke(SoapTr ansport.java:386)
    at com.zimbra.common.soap.SoapTransport.invokeWithout Session(SoapTransport.java:372)
    at com.zimbra.cs.account.soap.SoapProvisioning.invoke Request(SoapProvisioning.java:442)
    at com.zimbra.cs.account.soap.SoapProvisioning.invoke (SoapProvisioning.java:450)
    at com.zimbra.cs.account.soap.SoapProvisioning.soapAd minAuthenticate(SoapProvisioning.java:394)
    at com.zimbra.cs.account.soap.SoapProvisioning.soapZi mbraAdminAuthenticate(SoapProvisioning.java:422)
    at com.zimbra.cs.account.ProvUtil.initProvisioning(Pr ovUtil.java:758)
    at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java: 3472)
    Does anybody has an idea what the problem might be?
    I am using Centos 6.4 with the Network Edition (standalone).

  2. #2
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    8

    Default

    See following link is of any help to you.

    http://www.zimbra.com/forums/adminis...not-found.html
    ~=Prashant=~

  3. #3
    Join Date
    Aug 2013
    Posts
    2
    Rep Power
    2

    Default

    Quote Originally Posted by prashant View Post
    See following link is of any help to you.

    http://www.zimbra.com/forums/adminis...not-found.html

    Hi,
    I did not change any value in the link which you provide to me.

    But anyway I change the values but the error is still the same.
    Any further ideas?

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by faselbla View Post
    Hi,
    I did not change any value in the link which you provide to me.

    But anyway I change the values but the error is still the same.
    Any further ideas?
    Do you actually have the proxy installed? How about giving us a description of your ZCS configuration (single, multi-server etc.) and the output of these commands:

    Code:
    zmcontrol -v
    zmcontrol status
    Just for confirmation, please also post the output of all the commands from this sectionof a wiki article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Mar 2006
    Location
    Greenwood, IN
    Posts
    90
    Rep Power
    9

    Lightbulb One possible solution

    I observed a similar error today on a customer server. The "proxy" portion here refers to mailboxd's internal SOAP proxy, not the Nginx reverse proxy. Anyway, the error started after upgrading to 8.0.6 NE from 7.2.4:

    Code:
    $ zmprov
    ERROR: service.PROXY_ERROR (error while proxying request to target server: HTTP/1.1 404 Not Found)
    Check zmmailboxd.out for errors:

    Code:
    2014-04-24 23:13:18.858:WARN:/service:unavailable
    javax.servlet.UnavailableException: org/jivesoftware/wildfire/XMPPServer
           at com.zimbra.soap.SoapServlet.init(SoapServlet.java:128)
           at javax.servlet.GenericServlet.init(GenericServlet.java:241)
           at org.eclipse.jetty.servlet.ServletHolder.initServlet(ServletHold
           ...continues
    I found an unwanted set of libs in /opt/zimbra/lib/ext/zimbraiminterop, so I moved the directory aside, restarted mailboxd and the problem was solved.
    --
    Jason Bryan
    Zimbra R&D

Similar Threads

  1. Replies: 1
    Last Post: 07-22-2014, 03:39 AM
  2. Replies: 2
    Last Post: 08-20-2013, 10:27 PM
  3. Replies: 3
    Last Post: 02-24-2013, 08:27 PM
  4. Replies: 5
    Last Post: 01-28-2013, 09:09 AM
  5. Error while proxying request to target server
    By mwuertz in forum Developers
    Replies: 0
    Last Post: 03-01-2011, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •