Results 1 to 3 of 3

Thread: Admin console restore and zmrestore cannot find account listed in backup.

  1. #1
    Join Date
    Jul 2012
    Rep Power

    Default Admin console restore and zmrestore cannot find account listed in backup.

    trying to restore mailboxes of a deleted account in ZCS NE/EE 7.2.0_GA_2669.UBUNTU10_64

    from the admin console > backups > chose a date before the account was deleted, the account is listed in the backup, dated July 29 2013 6am (incremental, the previous full was July 19).

    I click restore when looking at that full backup, and choose restore single account and type in the accoun name@domain and click add to the list and then next.

    It attempts to restore and i get this:

    Message: invalid request: invalid account email address: Error code: service.INVALID_REQUEST Method: [unknown] Details:soap:Sender
    zmrestore from the command line also gives the same thing (tried with various full backups):

    Error occurred: no such account: Account ID for not found in backup full-20130711.100058.055
    grep accountBackup full-*/accounts/*/*/*/meta.xml | grep eliza

    only finds it back in a 201212* backup (yet she received mail up to june or july this year at least, account was deleted july 29 afternoon)

    I tried zmrestore before AND after recreating the account with the same name, but i get that error.


  2. #2
    Join Date
    Jul 2012
    Rep Power


    following this:

    Restoring a Single User from Backups Archived to Tape - Zimbra :: Wiki

    I see:

    <account zimbraId="3e4f37fd-2028-4f47-af0e-7373226b09a2" email="" latestFullBackupLabel="full-20121126.110019.837">

    why would an active user (til mid/late july) have the last full backup in 201212? I have other users with full backups from this past week and going back months - though various users are at various different times through the past - why arent full backups done of active users each week?

    I think i realise the problem. Im thinking full backups are a regular checkpoint, but they seem to be done only at the start of a user's account existence (why, i do not know). So if I use the first date in 2012 (2012-12-something), and then let it
    restore through all the redo logs (which takes forever and hammers the server badly...), then it will restore (or at least I hope, it's been going 10 min+ at high io load...)

    So that might be right, just need an explanation as to why Full backups arent done per user regularly on a system with only 50 accounts, but rather only once per user creation.


    Nope, fail!

    Error occurred: system failure: Error executing redoOp

    from mailbox.log:

    Caused by: com.zimbra.cs.mailbox.MailServiceException$NoSuchI temException: no such item: 10017
    Code:mail.NO_SUCH_ITEM ArgitemId, IID, "10017")

  3. #3
    Join Date
    Jul 2012
    Rep Power


    trying --ignoreRedoErrors, and its taking forever... 30min+ so far. see how this goes.

Similar Threads

  1. No backup tab in the Admin Console
    By axeplaya in forum Administrators
    Replies: 4
    Last Post: 12-03-2009, 10:12 PM
  2. Replies: 2
    Last Post: 06-23-2008, 11:58 AM
  3. Backup & Restore not available in admin (NE)
    By yogel in forum Installation
    Replies: 3
    Last Post: 02-04-2008, 07:45 AM
  4. restore deleted account with zmrestore
    By shanson in forum Administrators
    Replies: 8
    Last Post: 12-10-2007, 09:25 AM
  5. Backup options in admin console in 4.5.7
    By robh in forum Administrators
    Replies: 7
    Last Post: 10-01-2007, 06:29 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts