Hi,

We have a production and mirror mail server. Both servers are running CentOS 5.9 and ZCS 7.2.0. We use a script that rsyncs directories from the production server to the mirror server everyday. I noticed that any emails we click on in the mirror server starting around March 5, 2013 will give the following error message: "An unknown error (mail.NO_SUCH_BLOB) has occurred"

I searched this forum for other users getting the same issue. I found that at least one of them was told this could be an issue with indexing.

I checked our script and looked at the directories that are rsync'd from production to mirror.

I noticed 2 strange things:

1)

a)
From production machine: /mnt/backup/index/0
If you do an ls -l in this directory, you will get:

[root@mail 0]# ls -l
total 112
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 10
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 11
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 12
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 13
drwxr-x--- 3 zimbra zimbra 4096 Mar 15 2010 14
drwxr-x--- 3 zimbra zimbra 4096 Mar 16 2010 15
drwxr-x--- 3 zimbra zimbra 4096 Mar 19 2010 16
drwxr-x--- 3 zimbra zimbra 4096 Mar 25 2010 17
drwxr-x--- 3 zimbra zimbra 4096 Mar 31 2010 18
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 19
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 2
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 20
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 21
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 22
drwxr-x--- 3 zimbra zimbra 4096 Oct 29 2010 23
drwxr-x--- 3 zimbra zimbra 4096 Sep 6 2011 24
drwxr-x--- 3 zimbra zimbra 4096 Sep 7 2011 25
drwxr-x--- 3 zimbra zimbra 4096 Oct 13 2011 26
drwxr-x--- 3 zimbra zimbra 4096 Jun 21 2012 27
drwxr-x--- 3 zimbra zimbra 4096 Mar 5 2013 28
drwxr-x--- 3 zimbra zimbra 4096 Mar 27 14:18 29
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 3
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 4
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 5
drwxr-x--- 3 zimbra zimbra 4096 Mar 9 2010 6
drwxr-x--- 3 zimbra zimbra 4096 Mar 9 2010 7
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 8
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 9



b)
From the mirror server: /mnt/mail/index/0
If you do an ls -l in this directory, you will get:

total 104
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 10
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 11
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 12
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 13
drwxr-x--- 3 zimbra zimbra 4096 Mar 15 2010 14
drwxr-x--- 3 zimbra zimbra 4096 Mar 16 2010 15
drwxr-x--- 3 zimbra zimbra 4096 Mar 19 2010 16
drwxr-x--- 3 zimbra zimbra 4096 Mar 25 2010 17
drwxr-x--- 3 zimbra zimbra 4096 Mar 31 2010 18
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 19
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 2
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 20
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 21
drwxr-x--- 3 zimbra zimbra 4096 Oct 8 2010 22
drwxr-x--- 3 zimbra zimbra 4096 Oct 29 2010 23
drwxr-x--- 3 zimbra zimbra 4096 Sep 6 2011 24
drwxr-x--- 3 zimbra zimbra 4096 Sep 7 2011 25
drwxr-x--- 3 zimbra zimbra 4096 Oct 13 2011 26
drwxr-x--- 3 zimbra zimbra 4096 Jun 21 2012 27
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 3
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 4
drwxr-x--- 3 zimbra zimbra 4096 Mar 8 2010 5
drwxr-x--- 3 zimbra zimbra 4096 Mar 9 2010 6
drwxr-x--- 3 zimbra zimbra 4096 Mar 9 2010 7
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 8
drwxr-x--- 3 zimbra zimbra 4096 Mar 10 2010 9


So, for some reason the directory on the mirror server does not seem to have all of the files from the directory rsync'd to it from production server.



2)
If you look at the results from the production server, you will see that the latest timestamp is March 5, 2013. All emails from March 5 and later give the above mentioned error message on our mirror server. I am wondering if indexing is turned off on the production mail server.


How can I check if indexing is turned on or off?


Any help would be greatly appreciated.

Thanks.