Hello,

we have Zimbra cluster (Release 8.0.0_GA_5434.RHEL6_64_20120907144) with ldap master and two replicas.

Ldap service on master stopped working and I it wont start.

Here is the error I get:

[root@ldap-1 ~]# /etc/init.d/zimbra restart
Host ldap-1.bih.net.ba
Stopping vmware-ha...Done.
Stopping zmconfigd...Done.
Stopping stats...Done.
Stopping spell...Done.
Stopping snmp...Done.
Stopping cbpolicyd...Done.
Stopping archiving...Done.
Stopping antivirus...Done.
Stopping antispam...Done.
Stopping proxy...Done.
Stopping memcached...Done.
Stopping mailbox...Done.
Stopping logger...Done.
Stopping ldap...Done.
Host ldap-1.bih.net.ba
Starting ldap...Done.
Failed.
/opt/zimbra/bin/ldap: line 50: kill: (3716) - No such process
/opt/zimbra/bin/ldap: line 50: kill: (5654) - No such process
/opt/zimbra/bin/ldap: line 50: kill: (5664) - No such process
/opt/zimbra/bin/ldap: line 50: kill: (5674) - No such process
/opt/zimbra/bin/ldap: line 50: kill: (5684) - No such process
/opt/zimbra/bin/ldap: line 50: kill: (5694) - No such process
/opt/zimbra/bin/ldap: line 50: kill: (5704) - No such process
Failed to start slapd. Attempting debug start to determine error.
52396b12 ldif_read_file: checksum error on "/opt/zimbra/data/ldap/config/cn=config/olcDatabase={2}mdb.ldif"
52396b12 ldif_read_file: checksum error on "/opt/zimbra/data/ldap/config/cn=config/olcDatabase={3}mdb/olcOverlay={0}syncprov.ldif"
52396b12 <= mdb_index_read: failed (-30798)
52396b12 <= mdb_index_read: failed (-30798)
slapd: ./../../../libraries/libmdb/mdb.c:3447: mdb_page_search_root: Assertion `(((mp)->mp_pb.pb.pb_lower - ((unsigned) __builtin_offsetof (MDB_page, mp_ptrs))) >> 1) > 1' failed.


Any help would be appreciated.

Thanks!