Results 1 to 8 of 8

Thread: Setting the Zimbra server date/time

  1. #1
    Join Date
    Sep 2013
    Posts
    4
    Rep Power
    2

    Default Setting the Zimbra server date/time

    Hi,

    Had a look through the forums, didn't see anyone asking this question.

    Noticed my Zimbra server has the wrong time, 50 minutes in the future. I'd like to set it to the correct time.

    Is there an NTP daemon for Zimbra so that the clock doesn't get out of sync again?

    I have the vmware image of Zimbra that came with Ubuntu.

    Linux DOMAIN.com 2.6.32-41-generic #88-Ubuntu SMP Thu Mar 29 13:10:32 UTC 2012 x86_64 GNU/Linux

    v8.0.4_GA_5737

    Many thanks!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by flannell View Post
    Noticed my Zimbra server has the wrong time, 50 minutes in the future. I'd like to set it to the correct time.
    This is nothing to do with Zimbra, it's a question about your Linux Distribution and Zimbra gets it's time from your server.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Sep 2013
    Posts
    4
    Rep Power
    2

    Default

    Quote Originally Posted by phoenix View Post
    This is nothing to do with Zimbra, it's a question about your Linux Distribution and Zimbra gets it's time from your server.
    It's not my Linux distribution. It's Zimbra. As stated, I'm using their VMWare appliance v8 which looks like Zimbra have chosen Ubuntu. It would help to have NTP.

    Thanks.

  4. #4
    Join Date
    Jul 2013
    Location
    /dev/urandom
    Posts
    33
    Rep Power
    2

    Default

    Hi Flannel,

    In your appliance (the ubuntu), as a standard user or root run the command "date" like so:

    Code:
    [root@mail ~]# date
    Sun Sep 29 11:56:58 BST 2013
    [root@mail ~]#
    What does it output for you? is it still 50 minutes ahead?

  5. #5
    Join Date
    Sep 2013
    Posts
    4
    Rep Power
    2

    Default

    Quote Originally Posted by JakeMS View Post
    Hi Flannel,

    In your appliance (the ubuntu), as a standard user or root run the command "date" like so:

    Code:
    [root@mail ~]# date
    Sun Sep 29 11:56:58 BST 2013
    [root@mail ~]#
    What does it output for you? is it still 50 minutes ahead?
    Many thanks for your question.

    The time should be
    Sun Sep 29 13:53:40 BST 2013

    Zimbra thinks
    Sun Sep 29 14:43:40 BST 2013

    So it's fifty minutes in the future. I'd like a NTP process to keep the clock in sync if possible?

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Assuming that the host for the Appliance has the correct time, why don't you take the easy route and have the Appliance sync it's time with the host?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Join Date
    Jul 2013
    Location
    /dev/urandom
    Posts
    33
    Rep Power
    2

    Default

    Hi flannell,

    That indeed means, ubuntu it's self has it's clock set wrong, and not Zimbra.

    uBuntu is the (Virtualized) Operating System, Zimbra is the email server software.

    Zimbra get's it's time from the (Virtualized) Operating System, so in order to correct the time, you will need to tell uBuntu to set it's clock correctly.

    This is relatively trivial.

    So how? Simple, install and configure ntpd.

    Firstly, lets see if you have it installed, as root:

    Code:
    ntpd --version
    This should spit out a version, for example:
    Code:
    ntpd - NTP daemon program - Ver. 4.2.4p8
    However, if it exits, saying command not found, this means it's not installed, try:

    Code:
    sudo apt-get install ntp
    Once installed, try:

    Code:
    service ntp start
    This should sync up your clocks.

    Hope this helps!

  8. #8
    Join Date
    Sep 2013
    Posts
    4
    Rep Power
    2

    Default

    Jake,

    Many thanks. The Ubuntu OS that the Zimbra (v8) appliance has doesn't have any repo's setup.

    root@relay1:~# apt-get install ntp
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package ntp

    I'll look into the VM and getting that to take the date/time from the host ESX.

    Again, thanks for taking the time.

Similar Threads

  1. Setting up Zimbra for the first time.
    By duke8804 in forum Installation
    Replies: 2
    Last Post: 03-15-2012, 12:32 PM
  2. Replies: 1
    Last Post: 11-02-2011, 01:20 PM
  3. zimbra wrong time and date please help
    By andreskancrit in forum Administrators
    Replies: 2
    Last Post: 08-01-2010, 12:36 PM
  4. received date/time = import date time
    By dwatts in forum Administrators
    Replies: 0
    Last Post: 04-27-2010, 06:01 AM
  5. Date/Time problem on a Zimbra Box
    By rachid in forum Administrators
    Replies: 6
    Last Post: 09-01-2009, 11:13 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •