I tried to set postfix_smtp_sasl_security_options=anonymous before but if i send form a send mail gateway it said

anonymouse is not a recognised value for the option mail fail...etc