Results 1 to 4 of 4

Thread: Issues with outbound SMTP

Hybrid View

  1. #1
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    2

    Default Issues with outbound SMTP

    Hi All,

    I am having some issues getting outbound SMTP working.

    My ISP blocks port 25 both ways except for their servers and they also don't allow relaying through their servers.

    I use the dyn.com Mailhop and SMTP relaying services to get around these issues.

    I have inbound mail working fine but outbound is still causing me issues.

    My outbound mail ends up in the "deferred" queue because the messages get the following error: "Oct 5 06:59:59 phantom postfix/smtp[31834]: send attr reason = conversation with outbound.mailhop.org[204.13.248.72] timed out while receiving the initial server greeting"

    I can telnet to outbound.mailhop.org on 465 and get a connection BUT I don't get any response to my EHLO command.. it just closes the connection.

    Any thoughts on how to troubleshoot this further ?

    Regards

    Chris

  2. #2
    Join Date
    Dec 2006
    Location
    Minneapolis MN
    Posts
    777
    Rep Power
    9

    Default

    outbound.mailhop.org on port 465 uses SSL, and Zimbra's postfix doesn't account for that in a relay.

    I believe you may find information on how to tweak it to use SSL with the relay in the wiki.
    01 Networks, LLC / Cybernetik.net
    Zimbra NE and OSS Cloud Hosting
    Shared Web Hosting
    Consulting Services

  3. #3
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    2

    Default

    I am configured to use SSL/TLS and have followed the link you provided prior to posting this.

    Thanks for the suggestion though.

    If TLS was not enabled, I would get the "no suitable mech available" error I believe.

    Instead I just get no response.

    Regards,

    Chris

  4. #4
    Join Date
    Jul 2007
    Location
    US
    Posts
    67
    Rep Power
    8

    Default

    Based on what I've seen so far, it sounds like you're talking "in the clear" when you need to be on an ssl/tls channel instead. So, instead of:
    Code:
    $ telnet outbound.mailhop.org 465
    you would want to try:
    Code:
    $ openssl s_client -connect outbound.mailhop.org:465
    Then use your HELO/EHLO to get a response from the server. But then you need to make sure postfix is talking smtps instead of smtp (and then wanting to STARTTLS). Here are some useful references for this:


    Via that first link, you'll find the following statement (which leads you toward the second link provided above):
    The Postfix SMTP client does not support the obsolete "wrappermode" protocol, which uses TCP port 465 on the SMTP server. See TLS_README for a solution that uses the stunnel command.
    So if you do this, you'll setup stunnel as described in the second link and then tell postfix to route email through that tunnel.

Similar Threads

  1. Turn off outbound SMTP
    By cdunbar in forum Administrators
    Replies: 0
    Last Post: 07-25-2011, 12:17 PM
  2. Selected IP for SMTP outbound
    By deckard-x in forum Administrators
    Replies: 2
    Last Post: 03-02-2011, 09:53 PM
  3. SMTP outbound problem
    By duncan in forum Administrators
    Replies: 0
    Last Post: 01-16-2008, 09:26 AM
  4. Strange Outbound Issues
    By klarsen in forum Administrators
    Replies: 4
    Last Post: 07-06-2006, 09:37 PM
  5. Outbound SMTP Question
    By hikenboots in forum Administrators
    Replies: 3
    Last Post: 12-27-2005, 08:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •