Results 1 to 3 of 3

Thread: Installation problem with SSL Certificate in Zimbra 8.0.5

  1. #1
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    2

    Question Installation problem with SSL Certificate in Zimbra 8.0.5

    Hi,

    My SSL certificate just expired, and I tried to install new certificate and it fail, I tried searching the forum and Google everywhere and nothing works. So I'll post here and see anyone can help to solve, thanks.

    Zimbra Version: Release 8.0.5.GA.5839.UBUNTU12.64 UBUNTU12_64 FOSS edition

    I generated the CSR by using the following command:
    /opt/zimbra/bin/zmcertmgr createcsr comm -new -keysize 2048 -subject "/C=Country/ST=State/L=City/O=Organization/OU=Organization Unit/CN=mail.domain.tld" -subjectAltNames mail.domain.tld

    FYI, I am using RapidSSL.

    When I verify my SSL cert, this is what I got:
    root@mail:/opt/zimbra/ssl/zimbra/commercial# /opt/zimbra/bin/zmcertmgr deploycrt comm /tmp/commercial.crt /tmp/ca_chain.crt
    ** Verifying /tmp/commercial.crt against /opt/zimbra/ssl/zimbra/commercial/commercial.key
    XXXXX ERROR: Unmatching certificate (/tmp/commercial.crt) and private key (/opt/zimbra/ssl/zimbra/commercial/commercial.key) pair.
    XXXXX ERROR: provided cert isn't valid.

    Anyhelp and advise is very much appreciated. Thank you.

  2. #2
    Join Date
    Oct 2013
    Posts
    7
    Rep Power
    2

    Default

    try the sciprt referenced in the following thread.. might work for you

    http://www.zimbra.com/forums/adminis...rcial-csr.html

  3. #3
    Join Date
    Oct 2013
    Posts
    2
    Rep Power
    2

    Default

    Quote Originally Posted by csaroli View Post
    try the sciprt referenced in the following thread.. might work for you

    http://www.zimbra.com/forums/adminis...rcial-csr.html

    Tried that, didn't work for me.

    FYI, I am using the same method to install the certificate as last time. The only difference now is I have the generate a new CSR with "-keysize 2048".

Similar Threads

  1. [SOLVED] SSL certificate installation problem
    By yogesh2tech in forum Administrators
    Replies: 5
    Last Post: 06-04-2013, 08:27 AM
  2. Problem with SAN/UC Certificate installation
    By derek.rose in forum Administrators
    Replies: 0
    Last Post: 03-23-2010, 01:55 PM
  3. Replies: 5
    Last Post: 04-27-2009, 07:53 PM
  4. SSL Certificate Installation Problem
    By tkramis in forum Administrators
    Replies: 5
    Last Post: 05-07-2008, 05:59 PM
  5. [SOLVED] Certificate Installation problem
    By Insanity5902 in forum Installation
    Replies: 2
    Last Post: 12-27-2007, 01:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •