Hi,

My SSL certificate just expired, and I tried to install new certificate and it fail, I tried searching the forum and Google everywhere and nothing works. So I'll post here and see anyone can help to solve, thanks.

Zimbra Version: Release 8.0.5.GA.5839.UBUNTU12.64 UBUNTU12_64 FOSS edition

I generated the CSR by using the following command:
/opt/zimbra/bin/zmcertmgr createcsr comm -new -keysize 2048 -subject "/C=Country/ST=State/L=City/O=Organization/OU=Organization Unit/CN=mail.domain.tld" -subjectAltNames mail.domain.tld

FYI, I am using RapidSSL.

When I verify my SSL cert, this is what I got:
root@mail:/opt/zimbra/ssl/zimbra/commercial# /opt/zimbra/bin/zmcertmgr deploycrt comm /tmp/commercial.crt /tmp/ca_chain.crt
** Verifying /tmp/commercial.crt against /opt/zimbra/ssl/zimbra/commercial/commercial.key
XXXXX ERROR: Unmatching certificate (/tmp/commercial.crt) and private key (/opt/zimbra/ssl/zimbra/commercial/commercial.key) pair.
XXXXX ERROR: provided cert isn't valid.

Anyhelp and advise is very much appreciated. Thank you.