Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: LDAP issues after doing upgrade to zcs-8.0.5_GA_5839.RHEL6_64

  1. #1
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    5

    Default LDAP issues after doing upgrade to zcs-8.0.5_GA_5839.RHEL6_64

    I just completed the upgrade on an email server to 8.0.5_GA_5839 from 8.0.4_GA_5737
    .

    And I am getting an error regarding ldap that I can not seem to figure out where it is coming from.

    [zimbra@mail ~]$ zmcontrol start
    Host mail.hilltopchurchnet.net
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Starting ldap...Done.
    Failed.
    ldap_url and ldap_master_url cannot be the same on an ldap replica
    I know the Commercial SSL was set to expire in 4 days on the server.

    As well when the upgrade was done somehow the server got set to localhost for the hostname instead of the actual hostname, so not sure how that happened.

    This is a live production box that I need to have up pretty quick.
    Last edited by michael24; 11-10-2013 at 11:50 PM.
    ____________________
    Michael

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Try some of the solutions/debugging in these threads and post te relevant information if you have problems with getting this resolved:

    site:zimbra.com +"ldap_url and ldap_master_url cannot be the same on an ldap replica " - Yahoo Search Results
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    5

    Default

    Yep been through pretty much all of them that I can find on this issue the server worked fine before this upgrade and there were no network or dns changes as well.

    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.128.250 mail.hilltopchurchnet.net mail
    cat /etc/resolv.conf
    search hilltopchurchnet.net
    nameserver 192.168.30.3
    nameserver 192.168.128.230
    nameserver 8.8.8.8
    dig hilltopchurch.net any

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> hilltopchurch.net any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38842
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 9, AUTHORITY: 0, ADDITIONAL: 10

    ;; QUESTION SECTION:
    ;hilltopchurch.net. IN ANY

    ;; ANSWER SECTION:
    hilltopchurch.net. 3600 IN A 198.15.73.253
    hilltopchurch.net. 15 IN NS hcc1.hcc.hilltopchurchnet.net.
    hilltopchurch.net. 15 IN NS hcc2.hcc.hilltopchurchnet.net.
    hilltopchurch.net. 15 IN NS hccadvm1.hcc.hilltopchurchnet.net.
    hilltopchurch.net. 15 IN NS hcc3.hcc.hilltopchurchnet.net.
    hilltopchurch.net. 15 IN SOA hcc1.hcc.hilltopchurchnet.net. hostmaster.hcc.hilltopchurchnet.net. 48 10 10 15 15
    hilltopchurch.net. 15 IN MX 10 mail.hilltopchurchnet.net.
    hilltopchurch.net. 15 IN MX 20 mx.hilltopchurchnet.net.
    hilltopchurch.net. 3600 IN TXT "v=spf1 mx a:mail.hilltopchurchnet.net a:mx.hilltopchurchnet.net ip4:50.37.4.254 ~all"

    ;; ADDITIONAL SECTION:
    hcc1.hcc.hilltopchurchnet.net. 3600 IN A 192.168.128.231
    hcc1.hcc.hilltopchurchnet.net. 3600 IN A 192.168.128.176
    hcc1.hcc.hilltopchurchnet.net. 3600 IN A 192.168.128.230
    hcc2.hcc.hilltopchurchnet.net. 3600 IN A 192.168.128.235
    hccadvm1.hcc.hilltopchurchnet.net. 3600 IN A 192.168.128.234
    hcc3.hcc.hilltopchurchnet.net. 3600 IN A 192.168.128.233
    hcc3.hcc.hilltopchurchnet.net. 3600 IN A 192.168.30.232
    hcc3.hcc.hilltopchurchnet.net. 3600 IN A 192.168.1.233
    mail.hilltopchurchnet.net. 30 IN A 192.168.128.250
    mx.hilltopchurchnet.net. 3600 IN A 192.168.128.250

    ;; Query time: 5 msec
    ;; SERVER: 192.168.128.230#53(192.168.128.230)
    ;; WHEN: Sun Nov 10 23:31:17 2013
    ;; MSG SIZE rcvd: 496
    dig hilltopchurch.net mx

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.6 <<>> hilltopchurch.net mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37093
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2

    ;; QUESTION SECTION:
    ;hilltopchurch.net. IN MX

    ;; ANSWER SECTION:
    hilltopchurch.net. 15 IN MX 10 mail.hilltopchurchnet.net.
    hilltopchurch.net. 15 IN MX 20 mx.hilltopchurchnet.net.

    ;; ADDITIONAL SECTION:
    mail.hilltopchurchnet.net. 30 IN A 192.168.128.250
    mx.hilltopchurchnet.net. 3600 IN A 192.168.128.250

    ;; Query time: 2 msec
    ;; SERVER: 192.168.128.230#53(192.168.128.230)
    ;; WHEN: Sun Nov 10 23:31:54 2013
    ;; MSG SIZE rcvd: 124
    host `hostname`
    mail.hilltopchurchnet.net has address 192.168.128.250
    mail.hilltopchurchnet.net mail is handled by 10 mail.hilltopchurchnet.net.
    zmcontrol start
    Host mail.hilltopchurchnet.net
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Starting ldap...Done.
    Failed.
    ldap_url and ldap_master_url cannot be the same on an ldap replica

    Last edited by michael24; 11-11-2013 at 12:35 AM.
    ____________________
    Michael

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by michael24 View Post
    As well when the upgrade was done somehow the server got set to localhost for the hostname instead of the actual hostname, so not sure how that happened.
    I'm not sure which 'hostname' you, in ZCS or the server itself?

    Quote Originally Posted by michael24 View Post
    Yep been through pretty much all of them that I can find on this issue the server worked fine before this upgrade and there were no network or dns changes as well.
    Then you need to provide some information to show the current settings, are you sure your certificates were actually still valid? DO you have a backup of this server before the upgrade?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    5

    Default

    I just edited the post with all that information you normally ask for.

    I believe the backup is still good I am trying to confirm that though. The SSL is still good till the 11/16/2013 after the upgrade the new one was going to be installed.
    ____________________
    Michael

  6. #6
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    5

    Default

    Any one have any ideas?

    This also shows up during the upgrade

    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    HOSTNAME=mail.hilltopchurchnet.net
    LDAPHOST=
    LDAPPORT=
    SNMPTRAPHOST=
    SMTPSOURCE=
    SMTPDEST=
    SNMPNOTIFY=0
    SMTPNOTIFY=0
    LDAPROOTPW=zimbra
    LDAPZIMBRAPW=zimbra
    LDAPPOSTPW=zmpostfix
    LDAPREPPW=zmreplica
    LDAPAMAVISPW=zmamavis
    LDAPNGINXPW=zmnginx
    Last edited by michael24; 11-11-2013 at 01:37 AM.
    ____________________
    Michael

  7. #7
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    5

    Default

    This is crazy how does an upgrade do this:
    /opt/zimbra/libexec/zmsetservername -n mail.hilltopchurch.net
    Getting local config zimbra_home=/opt/zimbra
    Getting local config zimbra_server_hostname=mail.hilltopchurchnet.net
    Getting local config zimbra_ldap_userdn=uid=zimbra,cn=admins,cn=zimbra
    Getting local config zimbra_ldap_password=XXXXXXXX
    Getting local config ldap_is_master=false
    Getting local config ldap_url=
    Getting local config ldap_master_url=
    Getting local config ldap_starttls_supported=0
    Renaming mail.hilltopchurchnet.net to mail.hilltopchurch.net
    Shutting down zimbra...done.
    Getting local config ldap_host=
    Getting local config av_notify_user=
    Getting local config av_notify_domain=
    Getting local config snmp_trap_host=
    Getting local config smtp_source=
    Getting local config smtp_destination=
    Setting local config zimbra_server_hostname=mail.hilltopchurch.net

    Failed to get server config for mail.hilltopchurchnet.net.
    Unable to contact :
    Unable to contact :
    Services:
    This was set to localhost before I changed it appears that somehow the upgrade wiped out the settings is there away to re-setup the ldap setting back to default?
    ____________________
    Michael

  8. #8
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    5

    Default

    Fixed it

    Fortunately, I had a backup for the conf directory. I copied back any files that where empty (conf/ldap*, localconfig.xml, slapd*),

    The server is now up and running again.
    ____________________
    Michael

  9. #9
    Join Date
    Oct 2010
    Location
    Avondale, AZ
    Posts
    111
    Rep Power
    5

    Default Sloved

    Solved this issues just had to re run the upgrade again and everything went through fine.
    ____________________
    Michael

  10. #10
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default

    Thanks Michael for sharing the solution to that error

    Regards,
    Sebas

    Enviado desde mi Nexus 4 mediante Tapatalk

Similar Threads

  1. Replies: 1
    Last Post: 09-17-2010, 05:14 PM
  2. Upgrade: 4.5.5 -> 4.5.6 failed, LDAP/slapd issues
    By Daimyo in forum Installation
    Replies: 7
    Last Post: 08-04-2007, 10:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •