Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Web Interfaces Won't Start

  1. #1
    Join Date
    May 2006
    Location
    Reston, VA
    Posts
    34
    Rep Power
    10

    Default Web Interfaces Won't Start

    Details Centos 4.4
    zcs-4.5.0_GA_612.RHEL4

    Today I restarted the zimbra services with zmcontrol stop and then start. Everything seems to start ok, but the the admin console and webmail never come up. I see several httpd processes running but nothing listenting on 443 or 7071. The only logs I've have noticed that I think might be related are below.
    several of these in /var/log/zimbra.log
    Feb 2 14:57:07 postal perdition[9412]: Fatal error establishing SSL connection to client
    Feb 2 14:57:07 postal perdition[9413]: Fatal error establishing SSL connection to client
    Feb 2 14:57:07 postal perdition[9414]: Fatal error establishing SSL connection to client
    Feb 2 14:57:07 postal perdition[9415]: Fatal error establishing SSL connection to client

    and this in /opt/zimbra/audit.log

    [http-7071-Processor49] [ua=ZimbraWebClient - FF2.0 (Linux)/undefined;ip=144.232.*.*;name=myusername@mydomain. com] security - cmd=ModifyCos; name=myusername; zimbraAvailableSkin=; zimbraFeatureNotebookEnabled=TRUE; zimbraZimletAvailableZimlets=com_zimbra_tracking;z imbraZimletAvailableZimlets=com_zimbra_wikipedia;z imbraZimletAvailableZimlets=com_zimbra_url;zimbraZ imletAvailableZimlets=com_zimbra_ymaps;zimbraZimle tAvailableZimlets=com_zimbra_phone;zimbraZimletAva ilableZimlets=com_zimbra_xslt;zimbraZimletAvailabl eZimlets=com_zimbra_amzn;zimbraZimletAvailableZiml ets=com_zimbra_email;zimbraZimletAvailableZimlets= com_zimbra_date;zimbraZimletAvailableZimlets=com_z imbra_sms;zimbraZimletAvailableZimlets=com_zimbra_ rss;


    Thanks in advanced.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    What happened betwen today and the last time your server was running? What does a 'zmcontrol status' show?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    May 2006
    Location
    Reston, VA
    Posts
    34
    Rep Power
    10

    Default

    I enabled documents for one of my domains.
    Tomcat is the only thing that shows as not running, but it doesn't show any errors when i start and stop it.

    Host postal.insourcedsecurity.com
    antispam Running
    antivirus Running
    imapproxy Running
    ldap Running
    logger Running
    mailbox Stopped
    tomcat is not running
    mta Running
    snmp Running
    spell Running

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Have a look in the catalina.out log file and see what the errors are.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Join Date
    May 2006
    Location
    Reston, VA
    Posts
    34
    Rep Power
    10

    Default

    Here is an error out of the catalina.out file.

    zimbra server reserving server socket port=110 bindaddr=null ssl=false
    Fatal error: terminating: PrivilegedServlet init failed
    java.net.BindException: Address already in use
    at java.net.PlainSocketImpl.socketBind(Native Method)
    at java.net.PlainSocketImpl.bind(PlainSocketImpl.java :359)
    at java.net.ServerSocket.bind(ServerSocket.java:319)
    at com.zimbra.cs.util.NetUtil.newBoundServerSocket(Ne tUtil.java:111)
    at com.zimbra.cs.util.NetUtil.bindServerSocket(NetUti l.java:134)
    at com.zimbra.cs.util.NetUtil.bindTcpServerSocket(Net Util.java:63)
    at com.zimbra.cs.servlet.PrivilegedServlet.init(Privi legedServlet.java:94)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1105)
    at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:932)
    at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3915)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4176)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:910)
    at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:873)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:474)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:406)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at com.zimbra.cs.launcher.TomcatLauncher.start(Tomcat Launcher.java:52)
    at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatL auncher.java:74)

  6. #6
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    12

    Default POP server already running.

    You have a POP server already running on your system. Most likely this is a runaway Zimbra process. Check the forums for how to detect and kill running Zimbra tomcat processes (a search for "ps kill" will probably work).
    Bugzilla - Wiki - Downloads - Before posting... Search!

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Is this a single server? Did you, by any chance, enable the imap/pop3 proxy in the admin UI? If you did then disable it and restart Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    Join Date
    May 2006
    Location
    Reston, VA
    Posts
    34
    Rep Power
    10

    Default

    I did enable pop and imap proxy. How would I disable this via the command line?

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Try this as the zimbra user
    Code:
    zmperditionctl status
    to make sure that it is the problem, if it is then run the command again and stop perdition. When you've done that do a tomcat start and remove the option in the Zimbra Admin UI.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    Join Date
    May 2006
    Location
    Reston, VA
    Posts
    34
    Rep Power
    10

    Default

    zmperditionctl status
    imap4 is running
    imap4s is running
    pop3 is running
    pop3s is running

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. Zimbra .pids / service monitoring
    By bin2hex in forum Administrators
    Replies: 24
    Last Post: 04-03-2010, 09:12 PM
  3. After reboot mailbox and tomcat don't start
    By gon in forum Administrators
    Replies: 1
    Last Post: 11-02-2007, 11:50 AM
  4. web interfaces gone after zmtlsctl and blackout
    By mutinda in forum Administrators
    Replies: 2
    Last Post: 01-12-2007, 08:10 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •