Results 1 to 4 of 4

Thread: Updating Zimbra Host/Server Name

  1. #1
    Join Date
    Sep 2012
    Posts
    9
    Rep Power
    3

    Default Updating Zimbra Host/Server Name

    We have a zimbra FOSS installation that was originally created with the host/server name of zcs.domain.local. This is causing issues with certificate errors, since our certificate is actually for mail.domain.net. I found some instructions for updating this, but they are for Zimbra 6 and below; we are on Zimbra 8.0.5_GA_5839.FOSS, though.

    Any ideas on how to update this? It does not appear to be able to be changed in the GUI, and when I tried to follow the instructions for 6 and below, it did not work. Thanks for any assistance with this!

    --Charles

  2. #2
    Join Date
    Nov 2012
    Location
    Bangalore
    Posts
    173
    Rep Power
    2

    Default

    Follow this and you should be good

    1. Stop the flow of mail/Zimbra and take backup.
    2. The new hostname must exist in the DNS before zmsetservername is run. If it does not already exist in the DNS, we need to add the new hostname to the DNS now.
    Note: If the box is duplicate of production server, prevent this server from affecting the production server by halting communications between test and live servers.
    3. execute the following commands:
    su - zimbra
    /opt/zimbra/libexec/zmsetservername -o old.server.com -n new.server.com (replace old and new hostnames as per your requirement).
    4. Reconfigured the system for its new hostname as necessary for the operating system, (very important to do this AFTER step 3 - edited /etc/hosts & /etc/sysconfig/network files and update the new hostname in Red Hat).
    5. Reboot
    Cheers,
    Raun
    Always ready to help.

  3. #3
    Join Date
    Sep 2012
    Posts
    9
    Rep Power
    3

    Default

    Thanks Raunaq,
    That looks about like the same instructions as the 6.0 ones. But, I'll give it a shot. I'll try it tonight.

    --Charles

  4. #4
    Join Date
    Sep 2012
    Posts
    9
    Rep Power
    3

    Default

    Well, that was no luck... Everything appeared to work while running the commands, but after the restart kept getting errors that the logger did not start, and the mailboxd did not start... When I run zmcontrol status I get:
    Code:
     zmcontrol status
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Host mail.domain.net
            antispam                Running
            antivirus               Running
            ldap                    Running
            logger                  Stopped
                    zmlogswatchctl is not running
            mailbox                 Stopped
                    zmmailboxdctl is not running.
            memcached               Running
            mta                     Running
            opendkim                Running
            proxy                   Running
            snmp                    Running
            spell                   Running
            stats                   Running
            vmware-ha               Stopped
                    vmware-ha is not runnning.
            zmconfigd               Stopped
                    zmconfigd is not running.
    Any thoughts? Thanks for any further help...

    -Charles

Similar Threads

  1. Replies: 3
    Last Post: 06-12-2012, 07:20 PM
  2. Zimbra Desktop connection to Remote Host after Server Migration
    By elijahpaul in forum General Questions
    Replies: 0
    Last Post: 05-11-2012, 08:36 PM
  3. Moving zimbra server to new host
    By imnichol in forum Administrators
    Replies: 3
    Last Post: 08-03-2011, 04:58 PM
  4. Website & Zimbra Mail server on a same host.
    By nishith in forum Administrators
    Replies: 1
    Last Post: 07-11-2008, 11:25 AM
  5. Calendar not updating on server through outlook
    By doggiepowers in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 04-25-2007, 12:18 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •