Zimba Edition: Open Source Edition
Zimbra version: zcs-4.5.0_GA_612.RHEL4
Browser: Firefox 1.5.0.9 (Windows and Linux)

User has 51 entries in their Address Book and clicks on Address Book. Default view is Contact List. Immediately a window pops up with:

message - date has no properties

More info shows:
fileName - http://hostname.domainname/zimbra/js...v=070115200601
lineNumber - 4239
stack - (null)@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:4239
(null)@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:3791
(null)@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:5192
([object Object],false)@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:45823
([object Object],false)@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:45621
([object Object],false)@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:45500
([object Object])@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:46348
apply([object Object],[object Array])@:0
([object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:533
([object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:3765
("SELECTION",[object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:3618
([object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:11970
(7,true)@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:46137
([object Object],null,7)@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:46114
([object Object])@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:46705
apply([object Object],[object Array])@:0
()@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:533
([object Object],undefined)@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:46743
([object Object],undefined,undefined)@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:46695
("contacts")@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:60865
([object Object])@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:61324
apply([object Object],[object Array])@:0
([object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:533
([object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:3765
("SELECTION",[object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:3618
("SELECTION",[object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:9110
([object Object])@http://hostname.domainname/zimbra/js/ZimbraMail_all.js.zgz?v=070115200601:8800
apply([object Object],[object Array])@:0
([object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:533
([object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:3765
("onmouseup",[object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:3618
("onmouseup",[object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:9110
([object MouseEvent],"onmouseup",[object Object])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:9869
([object MouseEvent])@http://hostname.domainname/zimbra/js/Ajax_all.js.zgz?v=070115200601:9780
@:0

name - TypeError

[Real hostname was changed to hostname.domainname to protect the innocent. ]

When clicking on entries in the Contact List view, some entries to not refresh and show their current value... but show the previous entries value.

Oddly enough, switching to Detailed Cards view works fine... but switching back to Contact List view still shows bad info for many entries.

Tried switching themes (just in case it was a theme related issue), clearing cache and all of that... but seems to be a bug in the javascript?

I'm wondering if the 51 entries has anything to do with it.

Is this a bug?

I don't think the data is messed up where it is stored... and it appears to be just a display problem?