Results 1 to 2 of 2

Thread: Translation issue

  1. #1
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default Translation issue

    Hi,

    I'm trying to use po2prop/prop2po to merge an old translation (basque) of Zimbra with ZC8 "_es" files. Everything works great but there are 2 files that are giving me some trouble. I don't know what else to look...

    These are the files:
    - ZhMsg_es.properties
    - ZmMsg_es.properties

    This is the error message I get:
    processing 1 files...

    po2prop: warning: Error processing: input ZmMsg_eu.po, output ZmMsg_eu.properties, template ZmMsg_es.properties: Traceback (most recent call last):

    File "/usr/lib/python2.7/site-packages/translate/misc/optrecurse.py", line 528, in recursiveprocess
    fulltemplatepath)

    File "/usr/lib/python2.7/site-packages/translate/misc/optrecurse.py", line 583, in processfile
    **passthroughoptions):

    File "/usr/lib/python2.7/site-packages/translate/convert/po2prop.py", line 148, in convertprop
    outputprop = convertor.convertstore(includefuzzy)

    File "/usr/lib/python2.7/site-packages/translate/convert/po2prop.py", line 57, in convertstore
    outputstr = self.convertline(line)

    File "/usr/lib/python2.7/site-packages/translate/convert/po2prop.py", line 97, in convertline
    if unit.isfuzzy() and not self.includefuzzy or len(unit.target) == 0:

    AttributeError: 'NoneType' object has no attribute 'isfuzzy'

    [###########################################] 100%


    These are the commands I issue:
    prop2po --encoding=utf-8 ZmMsg_es.properties ZmMsg_eu.po
    po2prop -t ZmMsg_es.properties ZmMsg_eu.po ZmMsg_eu.properties --errorlevel=traceback

    The problem occurs when trying to "po2prop" the file. So far I tried to:
    - Play around with the .py script
    - Use the original files instead of the "_es" as source
    - Eliminate the old translation out of the equation. In this test I only tried to "prop2po" the english file and then "po2prop" it back. Sadly for me, IT GAVE THE SAME ERROR!

    This used to work...is anything wrong? Please help.

    Regards,
    Sebas

  2. #2
    Join Date
    Aug 2012
    Posts
    110
    Rep Power
    3

    Default

    Hi,

    I found the issue. After converting the file to .po and trying to save it, it always gave me the "duplicate message" error. The thing is that this error pointed to 8 entries duplicated (total of 16). After some manual search, I found that there was a ninth duplicated entry. Here is the complete list:

    offlineBackUpOptionEnable = Enable
    offlineBackUpOptionDisable = Disable
    offlineBackUpAccounts = Accounts:
    offlineBackUpEnable = Backup Accounts:
    offlineBackUpInterval = Schedule:
    offlineBackUpPath = Location:
    offlineBackUpKeep = Backup files per account
    offlineBackUpNow = Backup Now
    offlineBackUpButton = Backup Accounts Now

    These entries are present twice in the original files.

    Resuming:
    'NoneType' object has no attribute 'isfuzzy' > Caused by duplicated entries (at least in my case)
    Poedit tool, was not giving me the total number of duplicated entries.
    These entries are duplicated at least in "_es" and original english version of the files.

    Hope this helps someone else
    Sebas

Similar Threads

  1. Local mail issue or setup issue?
    By FlyingFish in forum Administrators
    Replies: 0
    Last Post: 09-22-2009, 10:04 AM
  2. add new translation
    By sameh in forum I18N/L10N - Translations
    Replies: 6
    Last Post: 04-14-2008, 07:59 AM
  3. 4.0 translation
    By Klug in forum I18N/L10N - Translations
    Replies: 5
    Last Post: 09-29-2006, 03:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •