I'm using ZSC Open Source 7.2.6 on Ubuntu 10.04 and I was about to upgrade to 8.x - actually 8.0.6 (previous releases can't upgrade version 7.2.6). But it fails on mysql tables upgrade with this message:

Code:
Upgrading from 7.2.6_GA_2926 to 8.0.6_GA_5922
Stopping zimbra services...done.
Starting mysql...done.
This appears to be 7.2.6_GA
Upgrading ldap data...done.
Upgrading LDAP configuration database...done.
Loading database...done.
Checking ldap status...not running.
Running zmldapapplyldif...done.
Checking ldap status...not running.
Starting ldap...done.
Checking ldap status...already running.
Running mysql_upgrade...done.
Redolog version update required.
Wed Jan  1 16:52:34 2014: Verified redolog version 1.31.
Wed Jan  1 16:52:34 2014: Updating Redolog schema version from 1.31 to 1.42.
Redolog version update finished.
Schema upgrade required from version 65 to 92.
Running /opt/zimbra/libexec/scripts/migrate20120611_7to8_bundle.plzmsetup.01012014-165121.log
Wed Jan  1 16:52:38 2014: Verified schema version 65.
Wed Jan  1 16:52:40 2014: Adding device information columns to ZIMBRA.MOBILE_DEVICES table...
Wed Jan  1 16:52:41 2014: Adding ZIMBRA.PENDING_ACL_PUSH table...
Wed Jan  1 16:52:42 2014: Adding TAG table...
...........
Wed Jan  1 16:52:54 2014: Adding TAGGED_ITEM table...
..........Wed Jan  1 16:52:56 2014: DB: CREATE TABLE IF NOT EXISTS mboxgroup60.tagged_item (
   mailbox_id    INTEGER UNSIGNED NOT NULL,
   tag_id        INTEGER NOT NULL,
   item_id       INTEGER UNSIGNED NOT NULL,

   UNIQUE INDEX i_tagged_item_unique (mailbox_id, tag_id, item_id),
   CONSTRAINT fk_tagged_item_tag FOREIGN KEY (mailbox_id, tag_id) REFERENCES mboxgroup60.tag(mailbox_id, id) ON DELETE CASCADE,
   CONSTRAINT fk_tagged_item_item FOREIGN KEY (mailbox_id, item_id) REFERENCES mboxgroup60.mail_item(mailbox_id, id) ON DELETE CASCADE
) ENGINE = InnoDB;: Can't create table 'mboxgroup60.tagged_item' (errno: 150)

Died at /opt/zimbra/libexec/scripts/Migrate.pm line 368, <OUTPUT> line 74.
Script failed with code 256:  - exiting
UPGRADE FAILED - exiting.
Is there any explanation for this?

I also tried to do release upgrade to 12.04.3LTS and perform upgrade but the result is the same. Log attached.